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Introduction

Welcome to DeltaPoint QuickSite, the fastest and most powerful way to 
create and manage a Web site on the Internet’s World Wide Web. Using 
QuickSite, you can create a professional-looking Web site. Whether you 
want to create a personal site for your friends and family or a complete 
presence with forms, download files, and links to other Hypertext Markup 
Language (HTML) files, QuickSite makes it easy!

QuickSite’s work-saving features speed up the process of Web site 
publication and make it possible for even the uninitiated to build a Web 
site in minutes. 

 

Web site wizards

QuickSite wizards walk you through steps to create Web site structure and 
links. There’s even a wizard to ensure a consistent style for your Web site!

QuickSite library

QuickSite’s library of predefined, reusable graphics and template forms 
gives you a head start on building your Web site. If you have existing 
documents and graphics, you can include them as templates in the 
QuickSite library or your own custom library. 

Hypertext technology

At the click of your mouse button you have the technology available to 
create HTML files (without knowledge of HTML code), import HTML-
coded files, and publish your complete site onto the Internet service you 
have selected.

Easy to use

No prior Web experience is required.
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Easy to maintain

You can change structure and settings, then regenerate the entire site with 
a few clicks of your mouse button.

Advanced database architecture

QuickSite’s database structure makes it easy to organize and update the 
information in your Web site so you can focus your efforts on improving 
your Web site — changing the content and organization, making layout 
more visually appealing, and helping users navigate your site in the 
quickest and easiest way possible.

What’s in this guide?
This user’s guide provides step-by-step instructions on how to perform 
specific tasks. Each of the chapters covers a group of related tasks. 

Chapter 1, 

 

Installing and Starting QuickSite

Describes how to install and start QuickSite.

Chapter 2, Key Concepts for Web Site Builders

Reviews concepts you need to understand before building a Web site. 

Chapter 3, Building a Basic Web Site

Walks you through the process of creating a basic Web site using 
QuickSite wizards. 

Chapter 4, Using the Project View

Describes how to use the Project View, QuickSite’s main Web site project 
creation window.

Chapter 5, Managing a Web Site Project

Describes the basics of creating and modifying a QuickSite Web site 
project.

Chapter 6, Changing Project Structure

Describes how to add and remove items

 

 (pages, components, and links) in 
the project structure.
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Chapter 7, Designing Web Pages

Describes how to use the QuickSite Page Designers to compose and 
format Web page text, including embedding HTML tags and graphics.

Chapter 8, Adding Project/Library Links and Templates

Describes how to use the QuickSite Page Designers to link to other project 
and library items and templates.

Chapter 9, Working with Graphics

Describes how to use the QuickSite Page Designers to add static graphics, 
clickable GIFs, and ImageMaps to your Web pages, and add professionally 
designed graphic themes.

Chapter 10, Designing Tables

Describes how to use the QuickSite Table Component Designer to design 
tables for inclusion in Web pages.

Chapter 11, Linking to Files and URLs

Describes how to use the QuickSite File Resource Component Designer 
and HTML Link Designer to link download files and URLs, respectively.

Chapter 12, Creating and Using Libraries

Describes how to use QuickSite libraries to store and retrieve frequently 
used items and to create custom libraries.

Chapter 13, Building, Testing, and Publishing a Web Site

Describes how to build a project, test its visual appearance and links, and 
publish it on the World Wide Web.

Appendix A, Resources for the WWW 

Lists online and printed resources to further your understanding of Web 
site creation.

Appendix B, Glossary

Provides a list of terms used throughout the manual and when using and 
creating your Web site.
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Terms used in this guide
This guide uses several specialized terms to describe actions performed 
with a mouse when using QuickSite.

Click

Press and release the mouse button.

Double-click

Press and release the mouse button twice in quick succession.

Select

Move the screen cursor (selection arrow) to a point on the screen, such as 
an options list, checkbox, or radio button , and click the mouse to 
make a choice.

Contacting DeltaPoint 
For the most current information about DeltaPoint, Inc. products and 
services, visit the DeltaPoint Web Site at 

 

http://www.deltapoint.com. 
The Web site contains product descriptions, reviews, specifications, 
downloadable demo software, bulletins, press releases, FAQ’s (Frequently 
Asked Questions), on-line users groups, and other useful information.

Technical Support

Phone 408-375-4700 (M-F, 7:00 am to 5:00 pm PST)

Fax 408-648-4048

E-mail tech_support@deltapoint.com

America Online (AOL) DELTAPOINT 

deltapoint@aol.com

Compuserve 76004,1522

76004,1522@compuserve.com
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Corporate

Mailing Address DeltaPoint, Inc.
22 Lower Ragsdale
Monterey, CA 93940

World Wide Web Site http://www.deltapoint.com

Phone 408-648-4000

Fax 408-648-4020

Sales

QuickSite Registration 800-446-6955 

Phone 800-446-6955 or 408-648-4000

 Fax 408-648-4025

 E-mail sales_support@deltapoint.com
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1
Installing and Starting 
QuickSite

This chapter describes how to install DeltaPoint QuickSite software on 
your computer system.

Before you install...
Before installing QuickSite, you need your hardware, software, and Web 
server to be set up properly.

Hardware requirements
Your computer hardware should satisfy these minimum requirements:

• Color Macintosh with 68030 or better processor.

• 3 MB of available RAM.

• 5 MB of available hard disk space. 10 MB for full installation.

• Internet connection — either direct (such as an ISDN or T1 link) or 
dial-up using a modem (preferably 14,400 bps or higher) with FTP 
(File Transfer Protocol) capability to publish your finished site. 

Software requirements
Software requirements include:

• Apple System 7.0 or later.

• Any Web browser program, such as Netscape Navigator, NCSA 
Mosaic, or Microsoft Internet Explorer.
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Web server
To post your Web site on the World Wide Web, you need access to a Web 
server that is visible to the Internet full-time. You can set up and maintain 
your own Web server individually (on a UNIX machine, PC, or 
Macintosh) or you can rent space on a server owned and maintained by a 
third-party Internet Service Provider (ISP).

ISPs, such as America Online, Compuserve, HoloNet, Netcom, Earthlink, 
and UUNet, to name a few, offer high-speed, local access to the Internet 
and World Wide Web through dial-up accounts for which you pay a 
nominal monthly fee. Ask your software retailer or consult the phone book 
for ISPs in your area.

Knowledge
You should be familiar with basic Macintosh operations, such as working 
with documents, folders, windows, menus, dialogs, and the mouse. If you 
are not familiar with these operations, please refer to your Apple Macintosh 
User’s Guide.

Installing QuickSite
The Macintosh installer provides two options — “Easy Install” and 
“Custom Install.” 

“Easy Install,” requires approximately 10 megabytes of hard disk space and 
is highly recommended because it ensures that you can take full advantage 
of all QuickSite’s options.

“Custom Install” lets you choose which groups of files you want to install. 
If you have limited hard disk space available, or do not plan to use certain 
QuickSite options, you may want to perform a custom installation. 

Note Before installing, we strongly recommend that you disable disk security, 
virus protection, and screen saver programs. If you have trouble during 
installation, restart your computer while holding down the Shift key to 
disable extensions (INITs). If the trouble persists, contact DeltaPoint 
Technical Services.
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To begin installation:
1. Insert QuickSite Disk 1 into your floppy disk drive.

2. Double-click the icon marked QuickSite Installer.

A window appears, containing detailed installation instructions and 
release notes.

3. Click the Print button to print the installation instructions and release 
notes.

You can also read the entire contents of the document by scrolling 
through it.

4. Following the installation instructions.

The default installation folder is DeltaPoint QuickSite™. Graphics are 
stored by default in the GIFs folder within the main DeltaPoint 
QuickSite™ application folder. The installation will take several 
minutes. This would be a great time to fill out your registration card.

Signing on to QuickSite
The first time you open QuickSite, a dialog appears asking you to enter 
your name, company name, and for new users, your program serial 
number. Use the Tab key to advance to the various fields. The serial 
number is printed on Disk 1 of the QuickSite installation disks.
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About the Main QuickSite window
The Main QuickSite window contains a Title bar with standard 
Macintosh functions. Below that is the tool bar. 

The command bar
The command bar contains menus of options you can click to access. In 
the start-up window, most of the menu options are grayed-out and 
unavailable.

This menu Contains options to...

File Create, open, save, close, and back up projects; import HTML files 
and Netscape Navigator bookmarks; exit.

Edit Undo changes; cut, copy, paste, insert, delete, and find items (pages 
and components); find and replace text; move through the Project 
View; change preferences. 

 

Title bar

command bar
tool bar
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The same menu bar appears in the Project View, the window you see after 
you create a new project or open an existing one. All of the menu options 
are accessible from the Project View (more on the Project View in 
Chapter 3, Building a Basic Web Site).

The tool bar
The tool bar contains buttons with tool icons that represent various 
shortcuts to access menu functions.

Tip When you point to a tool in the tool bar, QuickSite displays the tool 
description under the tool and at the bottom of the window.

Insert Insert pages (menu, text, and form) and components (paragraph, 
table, image, file link, URL, and external HTML file).

View Expand and collapse menu sections (menu pages and all their 
components); display or hide items; sort pages by edit date; create to-
do lists.

Project Build Web pages; build, test, and publish the Web site; check spelling; 
compress the project file.

Library Create, open, edit, and add to project libraries.

Wizards Run wizards for designing the Web site and individual Web pages.

Help Display and search online help; register QuickSite; display product 
and version information.

Tool Menu or Hint Shortcut 
key

Function

File | Open Project  

 

z-O Opens a Web site project.

File | Close Project z-W Closes the current Web site project.

Edit | Cut Web Page  z-X Cuts contents from a project page/
component and copies it to the 
Clipboard.
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Edit | Copy Web 
Page 

z-C Copies contents from a project 
page/component to the Clipboard.

Edit | Paste/Insert 
Web Page 

Pastes contents from the Clipboard 
into a project page/component.

Insert | Text Page Adds a text page.

File | Import HTML 
File 

Imports an HTML file into the 
current page.

Project | Build Web 
Site 

z-B Builds the entire current Web site 
project.

Project | Build Web 
Page 

Builds the current Web page only.

Project | Test Web 
Site 

Tests the current Web site project.

Project | Publish z-P Builds the current Web site project 
and uploads your site to the Web 
server.

Edit | Design Web 
Page 

Return Launches the Page Designer.

Edit | Delete Web 
Page 

Delete Permanently deletes the current 
Web page.

Edit | Change Web 
Page Status 

Toggle to change the status of a 
project page/component.

View | Collapse Collapses the Project View.

View | Expand ed Expands the Project View.

Edit | Find Web 
Page

Finds one or more Web pages.

Toggles to mark the current 
position in the Project View/return 
to the marked position.

? | DeltaPoint 
QuickSite Help

Displays online help.
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Exiting and restarting QuickSite
You can exit QuickSite and return to the Macintosh Desktop any time. 
When you are ready for another session, QuickSite is easy to start up 
again.

To exit QuickSite
From the File menu in the menu bar, choose Exit or press z-Q.

QuickSite terminates and returns you to the Desktop.

To restart QuickSite
Double-click on the QuickSite icon from within the DeltaPoint 
QuickSite™ folder.

The QuickSite start-up window appears on your screen.

Registering QuickSite
Take a moment to fill out and mail the registration card in your QuickSite 
package, or visit DeltaPoint’s Technical Support page on the World Wide 
Web (http://www.deltapoint.com)to fill in the registration form.

Note You need to be a registered QuickSite owner to turn off the QuickSite logo 
button,

,

which automatically appears on each Web page you create. For more on 
turning this button on/off, see Building and testing a Web site on 
page 13-1.
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Troubleshooting QuickSite
Using FAQ Central

If you cannot get a QuickSite feature to work or you have a question 
unanswered by this guide or QuickSite’s online Help, we recommend 
consulting QuickSite’s FAQ (Frequently Asked Questions) Central on the 
World Wide Web (http://www.deltapoint.com). 

DeltaPoint continuously updates its FAQ Central pages. You will find all 
kinds of interesting facts and tips there to help you. If your problem is still 
not solved, contact Technical Support at one of the numbers listed in How 
to contact DeltaPoint in the Introduction.

What to do if your computer hangs up
If your computer hangs up during routine QuickSite operations,

First try to open another project file. The first project file may have 
become damaged, QuickSite may be damaged, or you simply may not 
have enough RAM (QuickSite needs 8 MB to run.).

If the second project file works properly, then you know it was the first 
project file that was damaged and not QuickSite. Reinstall your 
project file from a backup or load the *.dbf file into Excel and save it.

Where to go from here...
If you are new to the world of Web sites, read Chapter 2, Key Concepts for 
Web Site Builders and, if you have never used QuickSite, read Chapter 3, 
Building a Basic Web Site. For detailed descriptions of specific QuickSite 
features, consult the remaining chapters in this guide.
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2
Key Concepts for Web 
Site Builders

This chapter introduces useful concepts for building your Web site. If you 
are an experienced Web builder, you might prefer to skip this chapter.

World Wide Web and the Internet
The Internet is a global network of computers that can talk with each other 
using common communication methods. You can gain access to the 
Internet through service providers — or your company may have a direct 
connection. Check with your network administrator.

The World Wide Web is an Internet service that lets you find and browse 
Web sites all over the world. It is an expanding and constantly changing 
repository of information for everything from scientific papers to retail 
catalogs to performance schedules to resumes.

The World Wide Web is the most rapidly growing part of the Internet, in 
part because so many corporations, institutions, associations, families, 
hobbyists, and individuals like you are finding the unrestricted access to 
such a wide range of information an invaluable benefit in their 
professional and personal lives.

What is a Web site?
A Web site is a presence on the World Wide Web. It presents your services, 
products, ideas, and talents to people all over the world, around the clock. 
It is the ultimate form of paperless self-publishing and it allows others with 
similar interests to find what you have to offer on-line.
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A Web site is a collection of linked documents (called Web pages) that 
contains information organized around a common purpose or function. 
For example, a mail order music company might publish its order form 
and catalog with musical excerpts that you can click and play on-line; a 
trade association might publish its newsletter and event schedule, or a 
stamp collector might publish his or her collection with a scanned image 
of each stamp and its asking price.

What is HTML?
Each Web page is formatted with hypertext markup language (HTML). 
HTML is a standardized set of programming codes (or tags) that are 
embedded in the Web page text. The HTML codes control how 
information is displayed and accessed through the World Wide Web.

For example, look at the following sample Web page text:

Here is how the text file of the above sample text looks with HTML codes:

 

Sample HTML Document
This is a document formatted using HTML. It is a plain text file that contains 
embedded markup codes.
When you view the document on the World Wide Web, these codes are 
hidden from view, but you can see them if you edit the document directly in a 
word processor or text editor.

 

<HTML>
<HEAD><TITLE>Sample HTML Document </TITLE></HEAD>
<BODY>
This is a document formatted using HTML. It is a plain text 
file that contains embedded markup codes.
<P>
When you view the document on the World Wide Web, these codes 
are <STRONG>hidden</STRONG> from view, <I>but</I> you can 
see them if you edit the document directly in a word 
processor or text editor.
</P>
</BODY>
</HTML>
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HTML gives you the ability to display information in a list or table 
format, embed graphical images, and manage other information such as 
hyperlinks (see below). 

With QuickSite, you do not have to know how to write HTML code! All 
you have to do is create the content of your Web site by entering or 
importing text and specifying styles. QuickSite does the rest. QuickSite 
creates the links and writes the HTML code. It even automatically 
includes advanced features such as a Table of Contents and return e-mail 
address. QuickSite also allows you to program in HTML to add special 
effects to your Web site, if you want.

What are hyperlinks?
HTML code is used to create hyperlinks, or jumps, to related pages within 
the same Web site or to other Web sites anywhere on the Internet. 
Clicking a hyperlink takes you directly to the linked information. A 
hyperlink can be text or a graphical image such as a button. Through 
hyperlinks, you can navigate to related information quickly and easily.

Hyperlinks are typically represented by colored, underlined text. For 
example, clicking

DeltaPoint Home Page

 

in your Web browser causes the browser to jump to the Web page defined 
by the hyperlink. In this example, clicking the hyperlink would be the 
same as typing 

 

http://www.deltapoint.com

 

 in your Web browser’s URL 
entry box. (The URL box is where you type 

 

http

 

 addresses to tell your 
browser the location of the Web page you want to visit.)
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How do I access a Web site? 
To be able to view information on the World Wide Web, you need:

• An Internet connection through your organization or an Internet 
Service Provider (ISP), a company that connects you to the global 
network for a fee.

• A Web browser program, such as Netscape Navigator, NCSA Mosaic, 
or Microsoft Internet Explorer, that can interpret and display pages 
written in HTML.

• A Uniform Resource Locator (URL) for the Web site you want to view. 
The URL is an address that identifies the location of a Web page. For 
example, to see the DeltaPoint home page, you would use the 
following URL: http://www.deltapoint.com. 

A Web site is stored on a Web server, a computer that is connected to the 
Internet and the World Wide Web. With your Web browser you can talk 
directly with any Web server on the Internet anywhere in the world. Your 
Web browser software and Web servers speak the same language, hypertext 
transport protocol (HTTP).

Here is how it all works:

1. Your Web browser receives an action from you, such as a URL (for 
example, http://www.deltapoint.com) or a jump to another Web 
page, and sends the request to the Web server via HTTP.

2. The Web server interprets the request, finds the requested page, and 
sends the text and associated graphics back to your Web browser via 
HTTP.

3. Your Web browser receives the page, interprets the HTML codes, then 
displays the page onscreen for you to view in your browser.

Tip You also can print Web pages from your browser.
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What does a Web site look like?
As an example, let us look at the DeltaPoint Web site. After you connect to 
the Internet and run your Web browser, you enter the URL of the 
DeltaPoint Web site: http://www.deltapoint.com. The DeltaPoint home 
page appears first (shown here by the Netscape Navigator browser). 

The navigation buttons on the DeltaPoint home page are custom, clickable 
graphics (GIF files), which jump to linked pages when clicked.

Scrolling to the bottom of the page reveals more graphics. 

 

URL

background

Web title as
graphic image

navigational
buttons

menu of text
hyperlinks
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Default navigation buttons, supplied by QuickSite, link the user with the 
Table of Contents and to a MailTo: form, where the user can send e-mail 
to the Webmaster, or administrator, of the Web site. 

At the very bottom, the DeltaPoint QuickSite logo button appears by 
default on all pages. Clicking this button takes the user to the DeltaPoint 
home page.

Tip Alternatively, you can elect not to include the DeltaPoint 
QuickSite logo button and other default navigation buttons and 
text when you build your site. For more information, see Building 
and testing a single Web page on page 13-4.

 

more clickable
graphics

default navigation
buttons

QuickSite
logo button
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Regions of a Web page
An HTML page consists of three regions as shown in the following 
example:

Header

The top portion of a Web page. Typically contains identifying information, 
including the page title and/or elements such as static graphics (for 
example, a company logo).

Body

The middle portion of a Web page. Contains the bulk of the information 
on a page including text, paragraphs, tables, images, lists, and navigation 
buttons.

Footer

The bottom portion of a Web page. Typically contains supplemental 
information including the copyright notice and the date the page was last 
saved.

 

header

header line

body

footer line

footer
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Optional horizontal header and footer lines visually separate the body from 
the header and footer regions, respectively. This visual arrangement 
organizes the screen for your Web site users, letting them quickly scan the 
screen for the information they want to see.
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3
Building a Basic Web Site

After you have installed QuickSite, you can use QuickSite’s New Project 
Wizard to help you build a basic Web site. This chapter guides you 
through a practice run with the New Project Wizard.

Note If you are new to the World Wide Web, we recommend you read 
Chapter 2, Key Concepts for Web Site Builders, before proceeding.

Creating a new Web site project
A project is the set of documents that makes up your Web site. QuickSite 
stores these documents in project files (which end with *.dbf and *.dbt). 
The project files contain information about all of the files, links, graphics, 
web pages, and other items that you use to create and manage your Web 
site. For more information, see About QuickSite projects on page 5-1.

When you build a project, QuickSite takes all of the information in your 
project files and generates the HTML (hypertext markup language) files 
that make up your Web site.

To create a new project
1. Start QuickSite.

The Create a New Project box opens.
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2. Type a project name, up to eight consecutive characters.

3. Click Create.

If the name already exists, a box appears asking if you want the 
existing file to be opened.

Using the project name you entered, QuickSite creates a folder in the 
QuickSite folder and adds empty project files (*.dbf and *.dbt) to 
that folder. For example, for project name mysite, QuickSite would 
create folder Macintosh HD:DeltaPoint QuickSite™:mysite and 
project files mysite.dbf and mysite.dbt.

4. At the prompt to use the New Project Wizard, click Yes. 

The Project Wizard begins.

Using the New Project Wizard
The New Project Wizard walks you through a step-by-step process for 
creating your new Web project, including:

• Home page (title and introductory text).

• Default settings for page components (auto-updating, header and 
footer lines, E-mail address).

• Page styles (background, header and footer lines, bullets).

• Web site structure (branching from home page).

• Page layout (center page titles or not).
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Note Any of the selections you make in the New Project Wizard can be changed 
for individual pages later, as covered in subsequent chapters of this guide.

Defining the home page
The New Project Wizard asks for the home page title.

To define a home page
1. Type a name for your home page or leave the default name, Home 

Page, for now. The title can be up to 64 characters long.

2. Click Next.

The New Project Wizard asks you to enter introductory text for your 
home page.
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3. You can type the text or select a text file to import. For this 
demonstration, click Import to import an introductory text file.

The Select A Text File To Import box opens with a list of text files to 
import from your QuickSite folder.

4. For purpose of demonstration, click the file named welcome.txt, then 
click Open.

QuickSite imports the text you selected and displays it in the New 
Project Wizard. 

5. Click Next to define default settings for the Web pages.

Defining autodate and header/footer line settings
By default, QuickSite selects all options in this wizard box. Selected 
options are checked. 
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6. Keep the default settings. This makes your Web page design consistent 
and makes it easier for users to navigate your site.

The default settings will produce the following results when you build 
your Web site:

Autodate Each Page 

QuickSite automatically informs your Web site visitors when your site 
last changed. The date that is generated appears automatically at the 
bottom of each page in your Web site.

Include Heading Line On Each Page

A header line appears as a horizontal rule directly below the title of 
each page. 

Include Footer Line On Each Page

A footer line appears as a horizontal rule directly below the body of 
each page. 

7. Click Next to define your E-mail address.

Specifying your E-mail address
The New Project Wizard asks you to specify your return E-mail 
address. This address is linked to the Send E-Mail navigation button 
on every page unless you turn the button off when building your Web 
site. For more information, see Building and testing a Web site on 
page 13-1.
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To specify an E-mail address
1. Type an E-mail address where your Web site visitors can contact you 

such as myname@aol.com. If you do not know your E-mail address, you 
can leave the address blank for now. You can always add or change the 
E-mail address later. For more information, see Setting/resetting 
preferences on page 5-5.

2. Click Next to define your Web page structure.

Selecting the Web site structure
The New Project Wizard first lets you select the Web site structure. The 
Web site structure defines the way your site is organized and how easily 
users can navigate pages to find the information they want.

You can choose one of three predefined Web site structures (Basic, 
Intermediate, and Advanced) or select from an extensive library of pre-
defined Web sites, such as Catalog Sales, Conventions/Conferences, and 
Corporate Presence, as provided by QuickSite.

Note You can easily add or remove pages once you are done with the New 
Project Wizard to change the Web site structure to suit your needs.

To select a Web site structure
1. Click the radio button in front of the option for the Web site structure 

closest to the Web site you want to build. When the radio button is 
black, , the option is selected.
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For this demonstration, select the Advanced option (third button 
from the top) so you can see the full variety of Web pages you can 
create for your practice site. 

2. Click Next to define the Web page style.

Defining Web page styles
The New Project Wizard opens the first Page Style box, which summarizes 
the types of styles you can specify.

Click Next to select a background style.
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Selecting a background
The New Project Wizard opens the next Page Style box, where you can 
select a background for your Web site. 

Although the background setting is optional, an attractive background can 
add visual appeal to your Web site. Backgrounds are typically small JPG 
images that tile seamlessly behind the text and graphics on your Web page.

You are not limited to the backgrounds provided with QuickSite. Many 
users will select a background that is consistent with corporate colors, 
logos, or personal tastes. You can copy your background JPG, GIF, or 
PNG files into the gifs folder in the QuickSite folder so they are 
accessible in the New Project Wizard.

Tip To optimize Web page readability, select a background with light color and 
simple texture, such as gray or yellow.

To select a background
1. Click Background.

The Select Image File box opens.

2. In Files of type, scroll and click to select a *.jpg or *.gif file. 
(QuickSite provided backgrounds are *.jpg and *.gif files.)

3. Click to select a background file, such as qs_chlk.jpg, from the files 
list.
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4. Click Open.

The Page Style box reopens.

5. Click Next to select header and footer line styles.

Selecting header and footer line styles
The New Project Wizard opens the next Page Style box, where you can 
select the color of header and footer lines on your Web pages.

Tip QuickSite provides several attractive header and footer line colors. When 
selecting a header or footer line, select a color that contrasts with the 
background color. The default line color contrasts with the current 
background (that is, dark on light background and light on dark 
background). For consistency in page design, select the same color for 
both lines. 

To select header and footer line styles
1. In the Header Line box, scroll and click the header line style you want.

2. In the Footer Line box, scroll and click the footer line style you want.

3. Choose Next to select a bullet style.



Defining Web page styles Building a Basic Web Site

3-10 DeltaPoint QuickSite User’s Guide

Selecting a bullet style
The New Project Wizard opens the next Page style box where you can 
select a color style for bullet lists in your Web site.

By default, bullets appear to the left of hypertext menu links on your Web 
pages. Bullets delineate choices and add an attractive, professional look to 
your Web pages.

To select a bullet style
1. In the Bullet List Item box, scroll and click a bullet color from the list.

2. Click Next to select the page title layout.
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Selecting a page title layout
The New Project Wizard opens the last Page Style box and displays the 
Center Page Titles option. The default is to align titles on the left side of a 
page.

To select a page title layout
1. Optionally select or deselect the Center Page Titles option as desired.

Tip You can always change the page styles you have set by 
selecting the Page Style Wizard from the Wizards menu.

2. Click Save to save your New Project Wizard settings and automatically 
generate the project files containing the pages for your Web site.

QuickSite closes the New Project Wizard and displays your Web site 
information in the Project View.
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Generating Web pages
At this point, QuickSite saves the settings you selected in the New Project 
Wizard and automatically opens the Project View, QuickSite’s main 
window for Web site development.

The Project View example below is what you see if you created the 
Advanced web structure in the New Project Wizard (see Using the New 
Project Wizard on page 3-2).

From the Project View, you can design, build, test, and publish your Web 
site project. The Project View displays a constantly updated overview of 
your entire Web site as you work on it. Each line in the Project View 
contains information about an item (page, page component, or link) in 
your Web site. 

For information on how to navigate the Project View and use its tools, see 
Chapter 4, Using the Project View. 
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Setting QuickSite preferences
Before you can build and test your Web site, you need to set basic 
preferences to tell QuickSite what paths to use to access the Web browser 
and GIF files on your computer. Additional preferences can be set later 
(see Setting/resetting preferences on page 5-5).

To set basic QuickSite preferences
1. From the Edit menu, choose Preferences.

The tabbed Preferences box opens.

2. In the Web browser path/executable window, click the “...” button 
and select the folder/filename path for the Web browser program 
(such as Macintosh HD:Applications:Netscape Navigator Folder 
:Netscape Navigator) on your computer. QuickSite needs this path 
so it can test and display your project locally (on your computer, not 
the Internet). 

3. Click Save.

QuickSite saves your preferences.

The preferences you selected are sufficient to initially build and test 
your Web site. Later you will want to add other settings. For more 
information, see Setting/resetting preferences on page 5-5. You are now 
ready to build and test your Web site.
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Building and testing your Web site
At this point, you have set up a basic Web site in your project file 
(mysite.dbf and mysite.dbt). However, no HTML documents have 
been generated yet. QuickSite does that for you when it builds the Web 
site.

To build and test a Web site
1. From the Project menu, choose Build Web Site. Or click the Build 

Web Site tool, . For more about QuickSite tools, see The tool bar 
on page 1-5.

The Web Site Construction Options box opens.

The example above shows the default settings in the Web Site 
Construction Options box. To deselect (uncheck) any of these 
options, click the option.
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The table below describes what occurs when each option is selected.

Web site construction options

Include Automatic Table of Contents Link:

On The Home Page A link to the Web site table of contents appears on the 
home page.

On All Menu Pages A link to the Web site table of contents appears on all 
menu pages.

On All Text Pages A link to the Web site table of contents appears on all 
text pages.

Page Features:

Include Web Author On 
Each Page

The name of the web author appears on each page.

Include Copyright On 
Each Page

A copyright notice appears on each page.

Include QuickSite Logo The QuickSite logo appears on each page.

Include Navigation 
Buttons

Navigation button graphics, such as 

appear on each page. Select this option or Include 
Navigation Text Hyperlinks.

Include Navigation Text 
Hyperlinks

Navigation text hyperlinks, such as 

[Home Page][Return to Menu][Table of Contents]

appear on each page. Select this option or Include 
Navigation Buttons.

Build Options:

Display This Dialog Next 
Time

This box appears the next time you build a web site. If 
you deselect this option, and you want the box to 
display, choose Build Web Site from the File menu and 
select the option.
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2. Click Build/Test.

QuickSite builds the Web site, generating HTML pages in the 
background according to the Web Site Construction Options you 
have selected. For each of the text and menu pages in your project file, 
a corresponding *.htm file now exists.

QuickSite loads your Web browser automatically and displays the 
home page of the currently selected Web site as it looks at this point. 

3. Scroll down the home page so you can examine its entire contents.
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4. Click the hypertext links, such as Text Page 1 in the example above, to 
look at other pages. 

Adding features to your home page
The home page is usually the first screen that users see when they browse 
your Web site. As such, it should be informative, brief, and enticing. Your 
users should be able to know, at a glance, the purpose of your Web page, 
what it contains, and how to find what they are interested in.

You can change the text and add graphics to the home page and other 
pages you created with the New Project Wizard. You do so with 
QuickSite’s Page Designers. 

Page Designers are dialog boxes where you select and enter the content for 
individual pages. When you save the content, QuickSite inserts it in the 
desired page. The Page Designers differ somewhat, depending on the type 
of page you are designing. For example, the Home Page Designer has 
different page link options than the Menu Page Designer.
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To add home page text and graphics 
1. In the Project View, click the Home Page line.

2. From the Edit menu, choose Design Web Page or press z-D.

The Home Page Designer opens.

Home page text you imported through the New Project Wizard (see 
Defining the home page on page 3-3) appears in the text entry area of 
the Home Page Designer. 

3. Type changes in any of the text entry windows, such as:

Change the Web site title

In Web Site Title, make the title the same as that in Home Page Title. 
The Web site title appears as the *.htm file name for the home page in 
your Web site when it is viewed on the World Wide Web. It is also the 
name given to your QuickSite project files. For consistency, Web site 
designers usually want the Web site title to be the same as the home 
page title.

Change the page title

In Home Page Title, change the existing title to the actual title you 
want displayed on your home page, for example, type QuickPress 
Enterprises. 
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Left-align the page title.

If you centered the title in the New Project Wizard, deselect Center 
Title. This causes the title to be left-aligned on the home page.

4. In the Optional Text box, type new text or change the displayed text.

5. Add some graphics to the page.

Add a Welcome banner to the top of the page.

Click Header GIF and, in the Select Image File box, locate the 
Welcome banner file, welcome.gif. This file is located in the GIFs 
folder (if you installed QuickSite in the default folder Macintosh 
HD:DeltaPoint QuickSite™:GIFs). Click Select to select the file.

The GIF file you selected will appear at the top of your home page 
when you build and test the project.

6. Click Save. 

QuickSite saves your work. The changed home page title appears in 
the Project View. The other changes you will see when you rebuild 
and test your file.
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About In Construction status...

Since you selected In Construction as the page status, QuickSite flags 
the title with the  icon and adds a yellow- and black-striped bar 
above the title. For more on changing the page status, see Changing the 
status of an item on page 4-8.

When you change the status back to Active, QuickSite removes the 
construction sign and bar.

Publishing your Web site
Each time you build your Web site, QuickSite stores all items used by the 
site in a folder called Publish in the project folder. For example, if your 
project is mysite, QuickSite stores the necessary files in the Macintosh 
HD:DeltaPoint QuickSite™:mysite:publish folder.

The Web site you have built, even in its unfinished, basic state, has all the 
elements necessary to publish on the World Wide Web. For how-to steps 
on publishing, see Chapter 13, Building, Testing, and Publishing a Web Site.

 

construction
bar gone

title centered
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4
Using the Project View

This chapter explains how QuickSite projects are structured and how the 
Project View, QuickSite’s main window, reflects that structure. The 
chapter also explains how you use the Project View to access pages and 
subordinate page components in your Web site project to work on them.

QuickSite project structure
QuickSite Web site projects are organized in a hierarchical structure 
designed for optimum efficiency and ease of use. The Project View is the 
cornerstone of your project. It shows what pages and page components the 
project contains. Through the Project View, you manage and update your 
Web site project. For more on managing, see Chapter 5, Managing a Web 
Site Project.

Project items
Each project is made up of one or more project items, including:

Home page

Top-most page in the Project View, typically contains welcome text, 
sometimes paragraphs and tables, and hyperlinks to any of the other 
project items. See the home page sample in What does a Web site look like? 
on page 2-5.

Table of Contents page

Automatically generated by QuickSite. This page is not listed in the 
Project View. Its attributes are determined by some of the properties set for 
the home page.
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Menu page

Automatically linked to the home page. Contains menu hyperlinks (with 
buttons) and usually some introductory text. A menu page can also 
contain text pages, form pages, paragraphs, tables, file links, URL links, 
and external HTML links. In the Project View, each menu page is 
associated, by default, with the home page and with items directly below 
it. See the sample menu page below.

Tip You can disassociate a menu page from the home page by 
changing the status of the menu page to Hidden. For more 
information, see Changing the status of an item on page 4-8.

Text page

Contains text in paragraphs and tables. A text page can be linked to the 
nearest menu page above it. It also can contain paragraph, table, and image 
components and is associated with the nearest home or menu page above 
it.

 

menu hyperlinks
with bullets
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Form page

Contain data entry fields designed like a form. Users can fill in the form 
and submit the data to your e-mail address. The form page is associated 
with the nearest home, text, or menu page directly above it. See the sample 
form page below.

Paragraph component

Paragraph text that is inserted directly into an associated home, menu, or 
text page.

Note In addition to the paragraph text, QuickSite adds to the associated page a 
text hyperlink for the paragraph component, if the page status for the 
paragraph component is Active. For more information, see Creating new 
paragraph and table components on page 6-2.

Table component

Table with variable rows and columns. You can turn on or off a table 
hyperlink and borders in the Table Component Designer. For more on 
tables, see Chapter 10, Designing Tables.

 

data entry
form
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Image component

Graphic image (*.gif, *.jpg, or *.png) hyperlink that can be inserted 
into a home, menu, or text page, table, or paragraph, as shown in the 
sample below. For more on image components, see Chapter 9, Working 
with Graphics. 

File Link component

Hyperlink to selected file links that can be inserted into a menu page. This 
lets you crate, in effect, “mini” ftp sites on your web pages. For more on 
file link components, see Chapter 11, Linking to Files and URLs.

URL link component

Hyperlink to another page, usually a home page on another site, using the 
other site’s URL (Uniform Resource Locator) that can be inserted into a 
text or menu page. For more on URL links, see Chapter 11, Linking to 
Files and URLs.

 

image
component
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External HTML page link component

Hyperlink to pages of information imported from external HTML files to 
an associated home, text, or menu page. For more on external HTML 
page links, see Chapter 11, Linking to Files and URLs.

The Project View
The Project View displays an outline of your Web site structure and is the 
point from which you create and maintain Web pages and their 
components. 

The Project View provides an outline of the page structure you saved in 
the project file for your Web site. The Project View lists project items 
(pages, their components and file links) in the hierarchy they are created 
for the Web site. That is, indented items are subordinate items in the 
structure. Thus you can see at a glance which item is at the top level of the 
structure — the Home Page. 

The Home Page has sub-pages (in the example above, Text Page 1 and Text 
Page 2) and links to Menu Pages. Each of the Menu Pages has sub-pages. 
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The Project View provides the following information about each item in a 
Web site: 

This column Tells you...

Type Page type. For more information, see Page types on page 4-7.

Status (not labeled) Page status (Active, In Construction, Hidden, or Suspended). 
For more information, see Page status on page 4-8.

Title Web page title.

New New! icon, optionally selected by double-clicking column. Puts 
New! icon next to hyperlinks to this page.

Hot HOT! icon, optionally selected by double-clicking column. 
Puts Hot! icon next to hyperlinks to this page.

Link Lists the type(s) of pages to which this item is linked. For more 
information, see Page types on page 4-7.

File HTML file associated with this page.

Date Date when this page was last saved.

Time Time when this page was last saved. 
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Page types
The Project View indicates the type of page and other item types in the 
Type and Link columns.  

Type Item contains...

Home Page Overview of Web site; the top-level page in page hierarchy.

Menu Page Menu of hyperlinks to other pages.

Text Page Text, graphics, and other content.

Paragraph 
Component 

A separate unit of text. A text page can contain multiple 
paragraph components to which hyperlinks can point.

Image Component A graphic with an associated hyperlink.

File Link Component Name, last save date, description, and size of downloadable file.

Form Page Data entry fields and buttons to submit the form to a specific 
address.

External HTML Page Pointer to an external HTML (HyperText Markup Language)-
coded file.

Table Component Grid of rows and columns of information.

URL Link HTTP link to an URL (Uniform Resource Locator); linked to 
menu pages only.
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Page status
The Project View displays the following types of status for pages in the 
Project View Status column. 

Changing the status of an item
You can change the status of an item to help you keep track of your project 
and separate items to view as a group, such as pages under construction 
and hidden pages. 

To change the status of an item
1. In the Project View, click an item for which you want the status 

changed.

2. From the Edit menu, choose Change Web Page Status or click the 
Change page status tool,  to change the status message. Repeat 
until the desired status displays in the Project View. 

Status type Indicates item is...

Active Included as an HTML file when the project is built and 
automatically referenced by menu pages if item is a menu, text, or 
form page. 

Hidden Included as an HTML file when the project is built but hyperlinks 
to this page are not included in the Web site. 

Use this status with paragraph, table, and other components that 
do not always need to be displayed, such as seasonal items, and can 
be hidden when you do not need them.

Construction Included as an HTML file when the project is built. The In 
Construction icon displays to indicate a page is currently under 
construction, like a draft that is not yet ready for final publication.

Suspended Not included as an HTML file when the project is built and, as a 
result, hyperlinks to this page are not included in the Web site.

Rather than deleting an item, use this status to retain the item in 
the project. Suspended status lets you archive items from earlier 
builds, thereby ensuring an audit trail and version control for your 
Web site.



Using the Project View Moving around the Project View

DeltaPoint QuickSite User’s Guide 4-9

Tip When you change the status for a menu page, you change the status of all 
subordinate links to that page. If you want to change the status of a menu 
page without changing the status of its subordinates, use the Page 
Properties box. For more information, see Chapter 7, Designing Web Pages.

To change the status of a menu page section
1. In the Project View, click a menu item for which you want the status 

changed.

2. Follow the procedure (above) for changing the status of an item.

The status message changes for every subordinate item in the menu 
page section. For example, if you set a menu page to Suspended, any 
linked text pages, URL links, and file links are suspended as well. 

Tip If you do not want to change the status of certain items in the menu, you 
can change their status back by individually selecting the page and clicking 
on the Change page status tool.

Moving around the Project View
You can easily move around the Project View and change the display to 
focus on an area of interest.

To scroll through the Project View
Use the scroll bars or the following keys to scroll through items in the 
Project View:

To move up one item, press the [

 

↑]  key.

To move down one item, press the [↓]  key.

To move up a page, press [Page Up].

To move down a page, press [Page Down].

To move to the home page
From the Edit menu, choose Top of Project. Or press [Home].
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To move to the bottom page
In the Edit menu, choose Bottom of Project. Or press [End].

Working with project items
You can select, move, and mark project items.

To select an item for editing
Scroll to the item, then click.

To move an item 
The sequence in which an item appears in the Project View determines its 
place in the page hierarchy. You can change where an item appears in your 
Web site by moving it in the Project View.

1. Point to the item you want to move.

2. From the File menu, choose Cut Web Page, press z-X, or click the 
Cut Web Page tool .

The item is removed from the Project View.

3. Click on the page above the row where you want to place the item.

4. From the File menu, choose Paste/Insert Web Page.

You can also replace the selected item with the cut item by choosing 
Paste/Replace Web Page.

To mark an item position
This feature is useful when working in a large QuickSite project with 
many items. You can mark an item, move to another item, then instantly 
move back to the marked item. 

1. In the Project View, click an item that you want to mark.

2. Click the Mark position tool, .

QuickSite remembers this location while you work in other areas of 
the project.
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To return to the previously marked item
Click the Mark position tool, , again.

QuickSite instantly returns to the previously marked item and unmarks it. 
To return to this location again, you must mark it again.

Collapsing/expanding the view
To see only the top level of your project structure, you can collapse the 
other items listed in the Project View to hide them. Later you can expand 
the items you collapsed so you can see the entire structure again.

Collapsing sections
In the Project View, you can collapse the home page or one or all menu 
pages. When you do this you also collapse all subordinate items on the 
page. You might do this, for example, to view the top-level of your project 
or to isolate a particular menu section on which you want to work.

To collapse the entire project
1. In the Project View, click the home page.
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2. From the View menu, choose Collapse, or click the Collapse tool, 
.

The entire Project View collapses to the home page and menu pages.

To collapse one menu page section
1. In the Project View, click a menu page or a subordinate menu item.

2. From the View menu, choose Collapse, or click the Collapse tool, 
. Just the items in the selected menu page collapse.

Expanding sections
From the Project View, you can expand a collapsed Project View so it 
redisplays all subordinate items under the collapsed section. 

To expand the entire project
1. In the collapsed Project View, click the home page.

2. From the View menu, choose Expanded, or click the Expanded tool, 
. The entire Project View expands to show all items.

To expand one menu page 
1. Click the collapsed menu page you want to expand.
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2. From the View menu, choose Expanded, or click the Expanded tool, 
. 

The menu page section expands to show all items.

Showing only certain item types
You can focus the Project View on a particular type of item, such as menu, 
text, or form pages, file links, or URL link components.

To show only menu pages
From the View menu, choose Menu Pages.

QuickSite displays only the menu pages in the Project View.

To show only text pages
From the View menu, choose Text Pages.

QuickSite displays only the text pages in the Project View.

To show only form pages
From the View menu, choose Form Pages.

QuickSite displays only the form pages in the Project View.

To show only file link components
From the View menu, choose File Links.

QuickSite displays only file link components in the Project View.

To show only URL link components
From the View menu, choose URL Links.

QuickSite displays only URL link components in the Project View.

Showing only hidden or in construction pages
You can change the Project View so it shows only those items that are In 
Construction or Hidden.
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To show only hidden items
From the View menu, choose Hidden Pages.

QuickSite displays only items with Hidden status.

To show only items in construction 
From the View menu, choose Construction Pages.

QuickSite displays only items with Construction status.

Showing items by a previous save date
From the Project View, you can show only those items that have been 
saved on, before, or after a specific date. For example, you might want to 
focus on the most recently changed pages.

To show items by a specified save date
1. From the View menu, choose By Date Last Modified.

The Filter Web Pages by Date box opens.

2. In Include Pages That Are, scroll and click the appropriate date 
delimiter, such as Less Than or Greater Than.

3. In This Date, type the save date.

4. Click Filter.

QuickSite displays only the items that match the date and date 
delimiter you specified.
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Showing items by keyword
You can quickly search through your site and find all page titles and page 
text containing a specific word, phrase, file path, or filename. After 
searching, QuickSite displays only those items that match your criteria. 

To search and show items by keyword
1. From the Edit menu, choose Find Web Page, or click the Find Web 

Pages tool, .

The Find Web Pages By Keyword box opens.

2. In Enter Key Word, type the word or phrase you want to find.

3. Click Search.

QuickSite searches through all items in the project and displays only 
those items that contain the text you entered.

Reshowing all items
From the View menu, choose All. Or select the home page and, from the 
View menu, choose Expanded.

QuickSite displays all items in the project.
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5
Managing a Web Site 
Project

Chapter 5 describes the basics of creating and modifying a QuickSite Web 
site project. It explains how to

• Create a new project.

• Open an existing project. 

• Save a project under a new name.

• Close a project.

• Set preferences.

• Manage multiple sites and projects.

• Maintain project files.

About QuickSite projects
A QuickSite project consists of all the items needed for QuickSite to build 
a complete Web site, including pages, paragraph components, file links, 
graphics, and so on. QuickSite stores and maintains all this Web site 
information in a project database. QuickSite uses the project database to 
manage your Web site items and generate the HTML code. 

Each QuickSite project database has three project files:

projectname.dbf

Stores the database structure, including item titles and other 
properties. 
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projectname.dbt

Stores the project text.

The project files are stored in a project folder by the same name. For 
example, a project named mysite would consist of three files, mysite.dbf 
and mysite.dbt, which reside in the mysite folder with a path such as 
Macintosh HD:DeltaPoint QuickSite™:mysite. 

Note Only the *.dbf file is visible when you open a project.

Creating a new project
For every new Web site, you need to create a new project (QuickSite 
automatically creates a new project database for you.). Using wizards, 
QuickSite makes it easy for you to create a complete, professional-looking 
Web site in minutes.

The wizards present you with a series of simple decisions to make about 
the structure and appearance of your Web site. When finished with this 
process, you will have a fully-functioning, fully-adaptable Web site that 
you can publish on the World Wide Web.

To create a project with the New Project Wizard
We recommend you use the New Project Wizard to create a basic Web site 
first. You can always customize it later.

1. From the File menu, choose New Project.

The Create a New Project box opens.

2. Type a project name, up to eight consecutive characters. 

Tip Do not place two projects in the same folder. Do not name a 
project index.*, contents.*, or myproj.*. Be sure the third 
character of the project name is not a number.

3. Click Create.

QuickSite creates the project files, using the project name you entered, 
and stores them in a QuickSite folder of the same name.

QuickSite then asks if you want to use the New Project Wizard. 
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4. Click Yes to use the New Project Wizard to build the new Web site.

5. Make your selections in the New Project Wizard. For more 
information, see Creating a new Web site project on page 3-1.

To create a project without the New Project Wizard
Although we recommend starting a new project with the New Project 
Wizard, you can start a new project without it.

1. From the File menu, choose New Project.

The Create a New Project box opens.

2. Type a project name, up to eight consecutive characters. 

Tip Do not place two projects in the same folder, and do not 
name a project index.*, contents.*, or myproj.*. Be sure 
the third character of the project name is not a number.

3. Click Create.

QuickSite creates the project files, then asks if you want to use the 
New Project Wizard. 

4. Click No to create the project without New Project Wizard assistance. 

5. Start creating...

From the Insert menu, select the pages and components you want to 
insert in the Project View.

From the Wizards menu, choose Page Style Wizard to define page 
layout and appearance (see Defining Web page styles on page 3-7).

From the Edit menu, choose Preferences to open the Preferences box 
where you can define program, project, and web site publishing 
preferences (see Setting/resetting preferences on page 5-5).
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Opening a project
You can open an existing QuickSite project file to inspect or edit its 
contents. Any changes you make during your editing session are saved 
automatically upon closing the project file or opening another project file.

To open a project
1. From the File menu, choose Open Project, or click the Open web site 

project file tool, .

The Select a Project box opens.

2. Select the folder and File Name of the project you want to open.

3. Click Open.

QuickSite opens and displays the file in the Project View.

Saving a project under a new name
You can copy a Web site project file by saving it under a new name. That 
way, rather than creating a Web site from scratch, you can use an existing 
project as your starting point, then modify it as needed to fit the particular 
needs of the new Web site.

Tip To simplify file management, do not save two project files in the same 
folder, especially if you have multiple sites. Instead, create a new folder for 
the Save Project As file.

Important!...Give the folder the same name as what you plan to give to the 
project file.

To save the current project under a new name
1. From the File menu, choose Save Project As.

The Save Project As box opens.

2. Select the folder where you want to save the file.

3. Type the File Name for the project.

4. Click Save.
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QuickSite saves the project under the specified name in the selected 
folder.

Closing a project
When you finish editing a Web site project file, you can close it.

To close the current project
From the File menu, choose Close Project, or click the Close current 
project tool, . QuickSite saves any changes, closes the project file, and 
closes the Project View.

Or open another project file. QuickSite saves any changes, closes the 
current project, and opens the next one.

To end your QuickSite session
From the File menu, choose Exit.

QuickSite saves any changes, closes the project file (if you have not), and 
shuts down.

Setting/resetting preferences
You need to set certain preferences so QuickSite knows the paths to access 
your Web browser and GIF files when it builds and tests your Web site. 
When you start a new Web project with the New Project Wizard, you set 
preferences. You can change preference settings from the Project View any 
time. 

To access QuickSite preference settings
1. From the Edit menu, choose Preferences.

The Preferences dialog box opens.
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2. Specify all of the following paths:

Web browser path/executable

Click the “...” button to search and select the folder/filename path for 
the Web browser program (such as Netscape Navigator) on your 
computer. Type the path yourself if you want. QuickSite needs this 
path for you to test and display your project locally (not on the 
Internet).

GIF viewer path /executable

Click the “...” button to the right of the “GIF Viewer Path/
Executable” field to browse for and select a viewer. 

The standard Open File box appears, so you can locate and select your 
GIF viewer. 

Mac GIF file library path

Specify the path for graphics in your project. This is the folder in 
which you place all of the graphic images that will be used in your site. 
Specifying this path instructs QuickSite to look in the proper folder 
for these files.

By default, this folder is Macintosh HD:DeltaPoint QuickSite™ 
:Gifs.
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When you install QuickSite, there is a gifs folder in the QuickSite 
folder. This is the folder to which the default path refers. It is 
recommended that you place all graphics in this folder.

3. Optionally, type the following information about your project:

Copyright

Type your company name to include a copyright at the bottom of 
every Web site page — Copyright © 1996 My Company Name - ALL 
RIGHTS RESERVED.

You do not need a copyright to publish a Web site.

Web author

Type your name or the name of the Web master responsible for your 
Web site.

Return E-Mail default

Type the default e-mail address to which user mail is directed, such as 
webmaster@webxxx.com.

4. Check the Unix GIF file library path.

The Unix folder/filename path establishes where the Web site user’s 
browser looks in the FTP target folder on the Web server to find and 
display graphics from your GIFS library. In most cases, the default 
blank (no entry) setting is recommended.

See the alternate Unix GIF path settings below:

blank (no entry) 

Default setting, used for most Web sites. Places all files for your 
entire Web site, including the default (QuickSite-provided) GIFS, 
HTML files, image files, and any referenced files in the FTP 
target folder on the Web server.

 

FTP target
all files



Setting/resetting preferences Managing a Web Site Project

5-8 DeltaPoint QuickSite User’s Guide

/gifs/ or /mygifs/

Places the default GIFS in a folder under the FTP target folder 
and places all other files in the FTP target folder. An alternative 
structure for sites when you want to keep your graphics separate 
from other sites.

../gifs/ or ../mygifs/

Places default GIFS (for all projects) in one folder and each 
project in a separate, FTP target folder. Used for multi-project 
sites with common graphics.

5. Type the following information:

User ID

User ID you use to log on the Web server. Maximum 32 characters.

Password

Password you use to log on the Web server. Maximum 32 characters.

Port number

Port number to connect to the Web server. Default port number: 21.

Important... Do not change this number unless specifically instructed 
to do so by your Internet Service Provider or Web Server 
Administrator.

FTP server address

Web server name. Maximum 64 characters. For example, 
ftp.yoursite.com.

 

FTP target
/GIFS/
all other files

 

FTP target
/GIFS/
/project 1/
/project 2/
/project 3/
/project 4/
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FTP target directory

Unix folder/filename path on the Web server that is the target for 
copying the HTML and GIF files to your Web site, in a format such 
as public_html. Maximum 128 characters.

6. Click Save to save preferences and Exit.

Managing related sites
For larger, more complex sites, you can use QuickSite to organize the site 
as a group of multiple subsites stored in separate project files and 
organized in a hierarchical structure.

In such an organization, the master site is the top-most project in the 
hierarchy, and all other projects below it are subsites.

Accordingly, the master home page is the top page of the master site and 
each subsite has a project home page, as shown in the following diagram:

For instance, suppose your company wants to sell its products and services 
on the World Wide Web and has a group of Web sites, each maintained by 
a separate division of the company. Using QuickSite, your company could 
create a multiple-site hierarchy similar to the following:

 

Master Site
master.htm

Subsite 1
project1.htm

Subsite 2
project2.htm

Subsite 3
project3.htm
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In this hypothetical structure:

• The corporate office, Corporate, creates and maintains the top-level 
project, called main. The main project contains pages describing the 
company, such as its background, contact information, annual report, 
quarterly financial reports, stock performance, and so on. The 
main.htm file is the master home page.

• The Products Division maintains Products. The products.htm file 
contains pages describing the various products the company offers, 
including specifications, pricing information, and scanned images.

• The Services Division maintains Services. The services.htm file 
contains pages describing the services the company offers, including a 
customer list. 

• The Sales Division maintains Sales. The sales.htm file contains pages 
that describe how to order products or services and includes an order 
form that users can complete and submit online.

Creating multiple Web sites 
You can use QuickSite to create multiple Web sites. This entails linking 
the home page of each subsite to the home page of the master site.

To link subsites to the master site
1. Create a new project for each of the sites, including the master site, as 

described in Creating a new project on page 5-2. Complete the 
remaining steps for each subsite.

 

Corporate
master.htm

Products
products.htm

Services
services.htm

Sales
sales.htm
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Tip All of your related sites should use the same library of 
commonly-used information, such as the company logo, 
URL links defined for each site, and paragraph components 
containing the company mailing address. For more on library 
links, see Adding QuickSite library links on page 8-3.

2. Double-click on the subsite Home Page.

The Home Page Designer opens. 

3. Select Link to Master Home.

Important!...This links the subsite home page to the master home 
page.

4. Type the URL (Uniform Resource Locator) for the master home page, 
for example http://mycorporation.com. The URL is specific to the 
subsite’s Home Page Designer.

5. Type a description of the master home page. This is used as a text link 
when Navigation Text Hyperlinks is selected in the Web site 
Construction Options box.

6. Click Save.
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QuickSite creates an automatic link to the master home page and, 
when you later build and test the Web site, displays a Home Page 
navigation button on the subsite’s home page. For more on page 
design details, see Designing a home page on page 7-3.

7. Click the Save.

QuickSite creates a Topic Home Page button on the page when you 
build the page or site.

8. Repeat the above process on each of your subsites.

Tip You also can link any of the subsite’s items (menu, text, or form page, or 
paragraph component) to the subsite’s home page. To do this, double-click 
an item you want to link, and, in the item’s Page Designer, select Link to 
Project Home.

Subsite text pages can be linked to the master home page as well.

Nesting menus
QuickSite automatically supports a three-level hierarchy structure, 
consisting of a home page, menu pages, and text pages with their assorted 
page components.

You can nest menus in that structure so that subordinate menus are listed 
under higher level ones. Nesting can be done for as many levels as you like, 
for example:

 

Menu level 1

Menu level 1a

Menu level 1b

Menu level 1b(1)

Menu level 1b(2)

Menu level 2

Menu level 2a

Menu level 2b



Managing a Web Site Project Nesting menus

DeltaPoint QuickSite User’s Guide 5-13

Tip Good Web design principles suggest keeping your menu structure as 
simple as possible so Web users do not get lost.

To create nested menus
1. In the Project View, create the top-level (master) menu and the 

submenus you want to nest.

2. Hide the first menu page you want to nest by changing the page status 
in the Project View to Hidden. Do this by clicking on the menu page 
and clicking the Change page status tool , until the status changes 
to Hidden. By changing the page status to Hidden, you tell QuickSite 
not to create a link to the page. For more information, see Changing 
the status of an item on page 4-8. 

3. Double-click on the menu page you want to nest. This opens the Page 
Designer. 

4. Change the Page Title to what you want displayed on the Web site.

5. Repeat steps 2 and 3 for the remaining menu pages you want to nest.

6. Manually link the menu pages together. 

To link manually, double-click on the master menu to open its Page 
Designer. In the Page Designer, click the Library and Project Links 
tool , and choose Project Links to open the list of items in your 
project. Double-click the first submenu page to link it to the master 
menu. Repeat process to link the remaining submenu pages to the 
master menu page. For more information, see Linking to items in your 
project on page 8-1.
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Maintaining your project
Your QuickSite projects need a minimal amount of maintenance. You 
need to back up your project files to protect against data loss. To optimize 
project storage space, you should compress large project files.

Backing up a project
You should back up your project files on a regular basis, perhaps daily or 
every time you make changes, to ensure recovery of your work if the 
original project files become damaged.

To back up the current project
1. From the File menu, choose Backup Project.

The Backup Project (project.dbf filename) To box opens.

2. Select a drive and folder where you can back up the project files. 

If you are on a network — the drive where your home folder is located 
on the network server is a good place to store your backup files.

If you do not work on a network — select another folder on your hard 
disk. Then after backup, compress the files (see below) and copy them 
to a floppy disk.

3. Keep the same file name.

4. Click OK.

QuickSite copies the project files (*.dbf and *.dbt) to the selected 
name and location.

Compressing project files
For projects containing a large number of items, you should periodically 
clean up your project files (*.dbf and *.dbt files) so your project builds 
accurately and efficiently. To do this, you use the Compress Project File 
option.

Compress Project Files verifies file names and removes files you marked for 
deletion (see Deleting items on page 6-9) so that unused disk space 
becomes available to your system and speeds up the build. 
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Compress Project Files also speeds your system by compressing the size of 
the reorganized files.

To compress project files
1. Back up the files so you always have an extra set of data that you can 

recover if needed.

2. From the Project menu, choose Compress Project File.

QuickSite compresses the project files and refreshes the Project View. 
The next time you open the project, QuickSite automatically 
decompresses the files.
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6
Changing Project 
Structure

Chapter 6 describes how to change the project structure, including how 
to:

• Create new items (pages and page components). 

• Add items, such as HTML files and bookmarks, from external sources.

• Delete items.

Creating new menu, text, and form pages
After you have created your initial project, you can create individual 
menu, text, and form pages in the Project View. 

For definitions of the different page types, see Project items on page 4-1. 
For how to add contents to pages, see Designing menu, text, and form pages 
on page 7-6.

To create a menu page
1. In the Project View, click a page below which you want to insert a new 

menu page.

2. From the Insert menu, choose Menu Page. 

QuickSite inserts a new, empty menu page.

3. Double-click on the page to open the Menu Page Designer. For more 
information, see Designing menu, text, and form pages on page 7-6.
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To create a text page
1. In the Project View, click a menu page below which you want to insert 

a new text page.

2. From the Insert menu, choose Text Page, or click the Insert text page 
tool, .

QuickSite inserts a new, empty text page.

3. Click on the page and, from the Edit menu, choose Design Web Page 
to open the Text Page Designer. For more information, see Designing 
menu, text, and form pages on page 7-6.

To create a new form page
1. In the Project View, click a menu page below which you want to insert 

a new form page.

2. From the Insert menu, choose Form Page. 

QuickSite inserts a new, empty form page.

3. Click on the page and, from the Edit menu, choose Design Web Page 
to open the Form Page Designer. For more information, see Designing 
menu, text, and form pages on page 7-6.

Creating new paragraph and table components
You can create paragraph and table components for QuickSite to add to 
your Web site pages. For definitions of the various component types, see 
Project items on page 4-1.

To create a paragraph component
Paragraph components contain paragraph text. They can be added to 
home, menu, and text pages.

1. In the Project View, select a page into which you want to insert a new 
paragraph component.

2. From the Insert menu, choose Paragraph Component.
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QuickSite inserts a new, empty paragraph component. The paragraph 
is automatically linked to the page. For more information, see 
Designing paragraph components on page 7-9.

To create a new table component
You can add table components to home, menu, and text pages.

1. In the Project View, click the page where you want to insert a new 
table component.

2. From the Insert menu, choose Table Component. 

QuickSite inserts a new, empty table component in the Project View.

3. Enter information to build in the table. For more on tables, see 
Chapter 10, Designing Tables.

Creating a new image component
You can add image (graphic) components anywhere in the project.

4. In the Project View, click the page where you want to insert a new 
image component.

5. From the Insert menu, choose Image Component. 

QuickSite inserts a new, empty image component in the Project View.

6. Select a graphic or ImageMap. 

Note You must link the image component to the page in order to display 
the graphic when you build and test the Web site. For more on 
graphics and how to link them, see Chapter 9, Working with Graphics.
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Creating File link and URL link components
You can insert components that link to resource files and URLs (Uniform 
Resource Locators) of other Web sites. For definitions of these component 
types, see Project items on page 4-1.

To create a resource file link
You can add resource file link components to menu and text pages only. 

1. In the Project View, click a menu or text page where you want to 
insert a new file link.

2. From the Insert menu, choose File Link.

QuickSite inserts a new, empty resource file link component in the 
Project View.

3. Double-click on the File Item in the Project View to display the Page 
Designer. Specify the filename and the location of the file on your 
computer or network.

QuickSite puts the file in your project folder, if it is not already there. 
On the Web, a user can download the file to the user’s computer by 
clicking the filename hyperlink. For more information, see Linking to 
a file on page 11-1.

To create a URL link
You can add URL (Uniform Resource Locator) on menu pages. URLs link 
the user to other http:// addresses on the World Wide Web.

1. In the Project View, click the menu page where you want to insert a 
new URL link.

2. From the Insert menu, choose URL Link.

3. QuickSite inserts a new, empty URL link component. 

4. Double-click on the File Item in the Project View to display the Page 
Designer. Add URL information. For more information, see Linking 
to a URL on page 11-4.
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Adding external HTML file sources
You can link to or import HTML files that were created outside QuickSite 
by a third-party HTML file editor. This lets you manage custom created 
pages within your Web site project, without editing the pages in 
QuickSite.

Linking to an external HTML file
You can add an external HTML file link to a home or menu page. This is 
an easy way to add to your project Web pages from external sources.

Tip You cannot edit the contents of a linked file from within QuickSite. You 
must go to the original, external file to change it. If the linked HTML file 
changes after building the Web site, you can update it on your Web site by 
rebuilding and publishing the Web site.

To create a new external HTML file link
1. In the Project View, select the page where you want to insert an 

HTML file.

2. From the Insert menu, choose External HTML Page.

QuickSite inserts a new, empty HTML file link component in the 
Project View. 

3. Double-click on the File Item in the Project View to display the Page 
Designer. Add file information as described in Linking to an external 
HTML file on page 11-7.

Importing HTML files
You can import an HTML page file created by a third-party HTML 
editor, like Adobe PageMill or Claris HomePage, into your QuickSite 
project. When you import a file, you bring the entire file contents into 
QuickSite’s Page Designer, where you can edit it. No link exists to the 
original file you imported as when you link to an external HTML file (see 
above). If the external file changes at its original source, you must reimport 
the file to access the changes.
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Important!...A HTML file created by a third-party HTML editor 
generally includes tags that QuickSite automatically adds, such as 
<HTML>, <TITLE>, and <HEAD>. These tags should be removed using 
the Page Designer.

Tip If you plan to use an existing HTML file as a model and change it to suit 
your needs, importing is the way to go.

To import an HTML file
You can import an HTML file to any of the home and menu pages.

1. In the Project View, select a home or menu page to which you want to 
add the HTML file.

2. From the File menu, choose Import HTML File, or click the Import 
HTML file tool, .

The Select an HTML File to Import box opens.

3. Locate and select the HTML file you want to import.

4. Click OK.

QuickSite creates an empty text page and imports the selected HTML 
file into the page. For information on editing HTML text, Chapter 7, 
Designing Web Pages.

Importing NetScape Navigator bookmarks 
You can use Netscape Navigator’s Bookmark feature to mark locations on 
the World Wide Web. You then can import these bookmarks to your 
QuickSite project so the marked locations are immediately available to 
your Web site users.

To create a bookmark
1. In Netscape Navigator, go to the page you want to bookmark.

2. From the Bookmarks menu, choose Add Bookmark.
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Netscape Navigator automatically adds the page to the bookmarks list 
at the bottom of the menu and saves the last page you marked in the 
bookmark.htm file in the Macintosh HD:Applications:Netscape 
Navigator Folder:Netscape Navigator folder or wherever Netscape 
Navigator is installed on your hard drive.

3. Close Netscape Navigator or leave it open if you want.

4. Go to QuickSite.

To import a bookmark
You can import a bookmark anywhere in your project.

1. In the QuickSite Project View, click the page where you want to insert 
the bookmark.

2. From the File menu, choose Import Bookmarks.

The Select a Bookmark File To Import box opens.

3. Find the Netscape Navigator folder that contains the bookmark file, 
such as Macintosh HD:Applications:Netscape Navigator Folder 
:Netscape Navigator, and select the bookmark file name, 
bookmarks.html. See To create a bookmark on page 6-6.

4. Click OK.

QuickSite creates a new menu page at the bottom of the Project View 
for the imported bookmark file. This page has the bookmark name.

For each bookmark you import, QuickSite also creates the URL link 
(http:// address) so users can access the page in your Web site.

If you wish to change the location of the bookmark page in the Project 
View, you can do so by cutting and pasting the page to another 
location. See Cutting, copying, and pasting items on page 6-8.



Cutting, copying, and pasting items Changing Project Structure

6-8 DeltaPoint QuickSite User’s Guide

Cutting, copying, and pasting items
You can use the Clipboard to cut and paste or copy and paste any of the 
items (pages or page components) in the Project View.

To cut an item
You can remove an item from one location and put it in another location, 
either within the same project or in a different project.

1. In the Project View, click the item you want to cut.

2. From the Edit menu, choose Cut Web Page, or click the Cut Web 
Page tool, .

QuickSite copies the cut item to the Clipboard, then removes it from 
the project.

To copy an item
You can copy an item to the Clipboard for pasting in another location, 
either within the same project or in another project.

For example, suppose you designed a text page that contains the default 
settings and elements you want for all pages throughout your site, such as 
a standard e-mail address and background. Once created, you can copy 
this page to the Clipboard, then paste it anywhere you want.

1. In the Project View, click an item you want to copy.

2. From the Edit menu, choose Copy Web Page, or click the Copy Web 
Page tool, .

QuickSite copies the item to the Clipboard.

To paste a new item
You can add the contents of another item you have cut or copied to the 
Clipboard from this or another Web site displayed on your local server or 
the World Wide Web.

1. Copy or cut the desired information to the Clipboard.

2. In the Project View, click the item below which you want to insert a 
new item.
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3. From the Edit menu, choose Paste/Insert Web Page, or click the Paste 
copied page tool, .

QuickSite adds to the Project View an item containing the contents of 
the Clipboard.

Replacing items
You can replace an item with the contents of another item that you have 
cut or copied from your Web site or another Web site to the Clipboard. 

To replace an item
1. Copy or cut an item. 

2. In the Project View, click the item you want to replace.

3. From the Edit menu, choose Paste/Replace Web Page.

QuickSite replaces the selected item with the contents of the item in 
the Clipboard.

Deleting items
You can delete items you no longer need

To delete a single item
1. In the Project View, click the item you want to delete.

2. From the Edit menu, choose Delete Web Page, or click the Delete 
current web page tool, .

QuickSite asks you to confirm the deletion. If the item contains 
components, QuickSite asks you if you want to delete all attached 
items.

3. Click Yes.

QuickSite marks the page as deleted (but retains the page in the 
project file). If you deleted the wrong page, you can undo the deletion 
(see below).
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Tip If you delete many items in your project, you should 
compress the project file to reduce its size and increase 
performance. For more information, see Compressing project 
files on page 5-14.

Instead of deleting an item you might need later, consider changing 
the status of the item to Suspended. Later retrieve the Suspended item 
by changing its status to Active. For more information, see Changing 
the status of an item on page 4-8.

Undoing the most recent deletion
Most changes that you make in the Project View are saved automatically 
and cannot be undone. However, if you accidentally delete an item, you 
can recover it as long as you do so before deleting any other items or 
closing the project.

To undo the last deletion
From the Edit menu, choose Undo.
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7
Designing Web Pages

The next three chapters describe how to design pages, components, and 
links in your web site project. This chapter describes how to use QuickSite 
Designers to display and modify the settings of each item.

It covers the following topics:

• Designing home, menu, text, and form pages 

• Designing paragraph, table, and image components 

• Designing file, URL, and external HTML links

See Chapter 9, Working with Graphics, for instructions on selecting 
graphic properties for your project. See Chapter 10, Changing Page 
Content, to change the body of home, menu, text, and form pages, as well 
as paragraph components. 

About the Designers
QuickSite provides Page, Link, and Component Designers with easy-to-
use entry forms for building and maintaining a Web site. You fill out the 
forms, selecting check box options, typing descriptive text, and possibly 
selecting files, then save your changes. You can lay out, format, and update 
individual pages, components, or links.

You can lay out, format, and update individual pages, components, or 
links using the right Designer for the job.
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A Text Page Designer...

...and its corresponding Web page:

.

 

Text Page Title,
Center Page Title

Web Page Text

Link to
Project Home

Link to
Master Home

Auto Date
Page

Display as New 
topic Hot topic

Include Header 
Line

Link to Menu 
Page

Response 
E-mail Address

Include Footer 
Line
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Designing a home page
The home page is automatically created when you create a new project. 
The home page is at the top level of your Web site and is typically the page 
at which you want your Web site visitors to arrive.

To design a home page
1. Click on the home page in the Project View.

2. Double-click on the home page from within the Project View, click on 
a page and choose Design Web Page from the Edit menu, or click the 
Page or Component Designer tool, .

The Home Page Designer opens.

3. Make the following changes as needed:

You can use the buttons above the Optional Text box to insert HTML 
tags, import text, or create project and library links. For more 
information on the use of these buttons, click the  button.

Web Site Title

Type the title for the Web site here. This title is not displayed but is 
embedded in the HTML code of each Web page to facilitate browser 
functions.

 

Page text
Graphics 
controls

Page names

Linking controls

Page status 
controls

E-mail address



Designing a home page Designing Web Pages

7-4 DeltaPoint QuickSite User’s Guide

Home Page Title

This name appears at the top of your Web home page, the first thing a 
user will see when accessing your Web site over the Internet.

Web Page Status

For the home page, you can choose between Active or In 
Construction. For more information, see Changing the status of an 
item on page 4-8.

Tip You also can change page status by choosing Change Web 
Page Status from the Edit menu.

Optional Text

Type or import the text you want to appear on this Web page. Click 
the , button to display the standard open dialog.

Link to Master Home

Select to create a link to the master home page for multiple sites. For 
more information, see Managing related sites on page 5-9.

URL

If this home page is part of a master site, specify the full URL 
(Uniform Resource Locator) address for the master home page on the 
World Wide Web, in http: address format, such as http:///
www.mycompany.com. Enter up to 128 characters.

Desc:

If this home page is part of a group of related sites, type a descriptive 
label for the master home page. It appears on Web pages when the 
Include navigation text option is selected when you build your Web 
site. For more information, see Building and testing a Web site on 
page 13-1.

Graphic Properties

Displays the Graphics Properties box so you can select graphics for 
your home page. For more information on using and placing graphics 
on the home page, see Chapter 9, Working with Graphics.
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Center Page Title

Centers the home page title in the middle of your Web site home 
page.

Include Header Line

Displays a header line on the page. Click the Graphic Properties 
button to select a header line graphic.

Initially you can choose to display a header line and the header line 
style through the New Project Wizard (see Defining autodate and 
header/footer line settings on page 3-4). 

Include Footer Line

Displays a footer line on the page. Click the Graphic Properties 
button to select a footer line graphic.

Response E-Mail Address

Type the E-mail address where you want to receive Web user 
responses.

Tip You can also add or change your E-mail address by selecting 
Preferences from the Edit menu.

4. Change ANY of the following display options, as needed.

Lock Text Format

Select to lock text in the format you specified for this page in the Page 
Designer. Locking text prevents Web browsers from inadvertently 
wrapping text and rearranging your layout when the browser window 
is resized. 

You do not need to lock text unless you have page formatting that 
must not be changed, such as source code or intricate text formats.

Auto Date Page

Select to display the date the page was last dated and saved. It displays 
at the bottom of the page.

5. Click Save.

QuickSite saves your changes to the selected home page.
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Designing menu, text, and form pages
The bulk of your Web site’s content will probably consist of menu, text, 
and form pages. Menu pages contain automatically-generated links to 
their sub-pages. Text pages are simply HTML pages that you can design 
and customize. Form pages contain forms that you design by entering or 
importing HTML forms code. 

All three of these designers work in essentially the same manner. Each has 
the same options for formatting, graphics properties, and HTML editing.

For information on adding a menu, text, or form page, see Creating new 
menu, text, and form pages on page 6-1.

To design a menu, text, or form page
1. Double-click on a menu, text, or form page from within the Project 

View, click on a page and choose Design Web Page from the Edit 
menu, or click the Page or Component Designer tool, .

The appropriate Page Designer appears.
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2. Make the following changes as needed:

You can use the buttons above the Optional Text box to insert HTML 
tags, import text, or create project and library links. For more 
information on the use of these buttons, click the  button.

Web Site Title

Displays the name of the home page. This field can only be changed 
from within the Home Page Designer.

Page Title

This name appears at the top of the particular Web page.

Web Page Status

Determines the usage status for the page. You can choose from Active, 
In Construction, Hidden, or Suspended. For more information, see 
Changing the status of an item on page 4-8.

Tip You also can change page status by choosing Change Web 
Page Status from the Edit menu.

Optional/Web Page Text

Type or import the text you want to appear on this Web page. Click 
the , button to display the standard open dialog.

The Form Page Designer includes additional HTML form templates 
and special form tags on the HTML Tags button. Because forms, by 
their very nature, execute CGI or mailto: operations, there is a special 
field provided that links to the action of the forms.

Link to Master Home

Select to create a link to the master home page for multiple sites. For 
more information, see Managing related sites on page 5-9.

Link to Project Home

Select to create a link for this page to the project’s home page.

Link to Menu Page

Text and Form pages only. Select to create a link for this page to the 
menu page above it.
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Graphic Properties

Displays the Graphics Properties box so you can select graphics for 
your page. For more information on using and placing graphics, see 
Chapter 9, Working with Graphics.

Center Page Title

Centers the page title in the middle of your Web page.

Include Header Line

Displays a header line on the page. Click the Graphic Properties 
button to select a header line graphic.

Initially you can choose to display a header line and the header line 
style through the New Project Wizard (see Defining autodate and 
header/footer line settings on page 3-4). 

Include Footer Line

Displays a footer line on the page. Click the Graphic Properties 
button to select a footer line graphic.

Response E-Mail Address

Type the E-mail address where you want to receive Web user 
responses.

Tip You can also add or change your E-mail address by selecting 
Preferences from the Edit menu.

3. Change ANY of the following display options, as needed.

Lock Text Format

Select to lock text in the format you specified for this page in the Page 
Designer. Locking text prevents Web browsers from inadvertently 
wrapping text and rearranging your layout when the browser window 
is resized. 

You do not need to lock text unless you have page formatting that 
must not be changed, such as source code or intricate text formats.

Auto Date Page

Select to display the date the page was last dated and saved. It displays 
at the bottom of the page.
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Display As New Topic

Select to display the New icon, , next to any hyperlinks to this 
page.

Display As Hot Topic

Select to display the Hot! icon, , next to any hyperlinks to this 
page.

4. Click Save.

QuickSite saves your changes to the selected page.

Designing paragraph components
Paragraph components are special blocks of text (that can include HTML) 
attached to menu and text pages. When you insert a paragraph 
component, QuickSite attaches it to the page under which it is inserted, 
including a reference to the paragraph at the top of the page, if specified. 

Note that paragraph components can consist of as much text or HTML as 
you like. They provide you with an easy means of managing a deeper 
hierarchy in your Web site by dividing text pages into discrete 
components.

For information on adding a paragraph component, see Creating new 
paragraph and table components on page 6-2

To design a paragraph component
1. Double-click on a paragraph component from within the Project 

View, click on a paragraph component and choose Design Web Page 
from the Edit menu, or click the Page or Component Designer tool, 

.

The Paragraph Component Designer appears. 
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2. Make the following changes as needed:

You can use the buttons above the Optional Text box to insert HTML 
tags, import text, or create project and library links. For more 
information on the use of these buttons, click the  button.

Web Site Title

Displays the name of the home page. This field can only be changed 
from within the Home Page Designer.

Paragraph Title

This name appears at the top of the paragraph. If you want the 
paragraph to appear without a title, leave the Paragraph title blank.

Paragraph Status

Determines the usage status for the paragraph. You can choose from 
Active, In Construction, Hidden, or Suspended. For more 
information, see Changing the status of an item on page 4-8.

Tip You also can change status by choosing Change Web Page 
Status from the Edit menu.

Paragraph Text

Type or import the text you want to appear in this paragraph. Click 
the , button to display the standard open dialog.
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The imported text can contain HTML tags.

3. Change ANY of the following display options, as needed.

Include in Page Contents List

Places the paragraph title with a hyperlink to the paragraph at the 
beginning of its associated page. This is a good wy to create a table of 
contents for a text page with many paragraph components.

Lock Text Format

Select to lock text in the format you specified for this page in the Page 
Designer. Locking text prevents Web browsers from inadvertently 
wrapping text and rearranging your layout when the browser window 
is resized. 

You do not need to lock text unless you have page formatting that 
must not be changed, such as source code or intricate text formats.

Display As New Paragraph

Select to display the New icon, , next to any hyperlinks to this 
paragraph.

Display As Hot Paragraph

Select to display the Hot! icon, , next to any hyperlinks to this 
paragraph.

4. Click Save.

QuickSite saves your changes to the selected page.
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8
Adding Project/Library 
Links and Templates

This c hapter is an extension of Chapter 7, Designing Web Pages. It explains 
how you can use Page Designer tools to:

• Link to other items in your project.

• Access items from the QuickSite library of reusable graphics and 
templates.

For more on libraries, see Chapter 12, Creating and Using Libraries.

Linking to items in your project
QuickSite makes it easy to change internal linking among items in your 
project. You can use the Project Links feature to add new hyperlinks for 
users to click and jump to. For instance, you might want to link an image 
component to another text page or link an order form page to a text page.

• You must link image and table components to their associated pages 
with the Project Links feature.

• QuickSite automatically links paragraph components to pages so you 
do not need to (and cannot) link them with the Project Links feature.

To link project items
1. In the Project View, double-click a page to open the Page Designer.

2. In the Optional Text window, click to mark the position where to 
insert a link to another project.

3. Click the Library and Project Links tool, .
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4. In the pop-up menu, choose Project Links.

QuickSite lists all the items currently in your project that you can link 
to. The left column displays the project item types.

5. Double-click the item you want to link to the page.

QuickSite identifies the selected link in the text entry window. For 
example, if you select the QuickSite Overview page as the link, the 
link is identified as ^QuickSite Overview^ in the text entry window.

 

project link
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6. When done with the Page Designer, click Save.

When you build and test the Web site, a hyperlink appears where you 
inserted the project link on the page.

Adding QuickSite library links
You can add interest to a page by adding one or more graphics, URL links, 
or other items that QuickSite provides in its library file, library.dbf. For 
instance, you might want to add a graphic to draw the reader’s attention to 
a particular part of the page.

The graphic items are linked directly into your Web page text and you 
cannot change them through the Page Designer.

Note In addition to using the QuickSite library file, you can create a library of 
your own custom graphics and other items, or you can add to the 
QuickSite library. For more information, see Chapter 12, Creating and 
Using Libraries.

To add library items to a page
1. In the Project View, double-click a page to open the Page Designer.

 

project link
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2. In the text entry window, click to mark the position where you want 
to insert a graphic or link from the QuickSite library.

3. Click the Library and Project Links tool, .

4. In the menu that opens, choose Library Links.

QuickSite opens a box that lists all items in the QuickSite library. The 
left column displays the item types. 

5. Double-click the item you want to insert in the page.

QuickSite inserts the selected link directly in the text entry window. 
For example, if you select Gold Star from the library, QuickSite 
identifies it as ^Gold Star^ in the text entry window. The ^ ̂  symbols 
indicate the graphic is linked and will be displayed on the page.

 

Double-click a graphic
from the library
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6. When done with the Page Designer, click Save.

When you build and test the file, the selected library item appears on 
the page where you inserted it in the page. [zot pic linlnkex2a.tif ]

 

linked Gold Star
from library

typed text

 

Gold Star
library item

typed text
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Using library content as a template
You can get a head start on Web page design by adding predefined 
QuickSite templates for text, graphics, and forms to your Web pages. 
Templates from the QuickSite library differ from library links in that you 
can change templates to suit your purpose.

For instance, you can add scrolling text to the bottom of your Web pages 
by selecting the Java Script Scroller template and then customizing it. 
Templates are also available for a variety of forms, such as guest books and 
order forms, that you can tailor to your needs.

To add templates
1. In the Project View, double-click a page to open the Page Designer.

2. In the text entry window, click to mark the position where you want 
to insert a graphic or link from the QuickSite library.

3. Click the Library and Project Links tool, .

4. In the menu that opens, choose Library Templates.

QuickSite opens a box that lists all templates in the QuickSite library. 
The left column displays the item types. 

5. Double-click the template you want to insert in the page.
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QuickSite inserts the selected template directly in the text entry 
window. For example, if you select Guest Book, QuickSite inserts the 
outline (with HTML code) that you can use to build a guest book for 
your Web site. You can use it as is or edit any text you want changed. 

6. When done with the Page Designer, click Save.

When you build and test the file, the selected template will appear on 
the page where you inserted it.

 

Guest Book
template
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9
Working with Graphics

Appealing Web sites use graphic images, such as pictures, buttons, and 
ImageMaps, to convey information to your users. QuickSite supports the 
following types of graphics:

Static graphics

Company logos, menu bullets and other images that are displayed but 
have no hyperlinks.

Clickable GIFs

Graphic navigation buttons and other graphics that have single hotspots, 
which jump to another location in your project or another Web site.

ImageMaps

Graphics that are mapped with multiple hotspots to other locations inside 
or outside your project. ImageMaps require special mapping software and 
generally cannot be tested locally.

This chapter is an extension of Chapter 7, Designing Web Pages. It explains 
how you can: 

• Select graphics for your header and footer,

• Select a background for any of your pages,

• Insert image components into your Project,

• Attach static or clickable graphics to your page,

• Turn off the QuickSite logo and/or navigation buttons.
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Selecting graphics properties
You can change the way graphics appear on a single Web page, within a 
menu section, or throughout your Web site.

The Graphics Properties button within the Page Designer box presents 
options to change the header and footer line styles, bullet colors, and 
background that you selected (see Defining Web page styles on page 3-7). 
The Paragraphs Page Designer does not have a Graphics Properties button.

The Graphics Properties box also lets you select GIF graphics for the 
menus, headers, and footers of any page type (except paragraph 
components).

You can also select the same graphics properties with the New Project 
Wizard (see Defining Web page styles on page 3-7).

In general, graphics should be used consistently throughout your Web site, 
with each visual variation used only to organize information or to add 
clarity to your site content. For example, within each menu section, you 
might use a different menu graphic file to provide the user with a visual 
cue about where they are in the Web site.

To change graphics properties
1. Double-click on any page in the Project View to display the Page 

Designer window.

The Page Designer box opens.

2. Click the Graphics Properties button.

The Graphics Properties box opens.
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3. Make your selections as needed.

Header Line Style

Click on the pop-up menu and choose a header line color. Default 
contrasts with the background (dark on light, or light on dark).

Each page can have a header line and footer line that visually separates 
the main body of the page from the top and bottom of the page. Such 
horizontal lines help your users organize and prioritize the 
information on the page. 

Note On a single page, the line styles should be the same for both 
the header and footer, and they should be consistent 
throughout the Web site. In addition, the selected color 
should visually contrast with the selected Background.

Footer Line Style

Click on the pop-up menu and choose a footer line color. Default 
contrasts with the background (dark on light, or light on dark).

Note For header lines and footer lines to appear on a page, its 
corresponding Include Header Line and Include Footer Line 
settings must be SELECTED in the Page Designer box.

Bullet List Item

Click on the pop-up menu and choose a bullet color. Default 
contrasts with the background (dark on light, or light on dark).

Bullet lists can appear on the home page and on menu pages in a 
project. A small graphic appears to the left of a bullet list item. 

Note The selected color should visually contrast with the selected 
Background.

Background

Click Background to open the Select a Background box, select a 
*.jpg, *.gif, or *.png file, and click OK.

The page background provides the canvas upon which you paint a 
Web page. In QuickSite, you can select the JPG (JPEG image) file you 
want to use for a page background.
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The background color you use should be appealing but unobtrusive 
enough to allow the foreground text and graphics to stand out visually.

Note QuickSite tiles (repeats) the JPEG image on the web site. 
Therefore, we recommend selecting as small a JPEG image as 
possible.

Header GIF

Click Header GIF to insert a graphic in the header of this page. In the 
Select a Page Header box, select a *.jpg, *.gif, or *.png file and click 
OK.

Footer GIF

Click Footer GIF to insert a graphic in the footer of this page. In the 
Select a Page Footer box, select a *.jpg, *.gif, or *.png file and click 
OK.

Menu GIF

Click Menu GIF to insert a small graphic, such as a gold star, in place 
of the bullet in front of the menu page hyperlink on the home page. 
The graphic you select also appears to the left of the menu page title.

Note See Selecting the scope of changes to graphics properties on page 9-5 for 
information on using the radio buttons.

4. Click Save to save your changes and return to the Page Designer.

Note For header lines and footer lines to appear on a page, the 
Include Header Line and/or Include Footer Line options 
must be SELECTED.

5. Click Save to save your changes in the Page Designer.
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Selecting the scope of changes to graphics properties
You can determine whether to apply changes in graphics properties to the 
selected page, selected menu section, or the entire Web site. In this way, 
you can set a default site-wide graphical style, then selectively depart from 
that standard by menu section or even by page.

Note To ensure a consistent look to your web site, QuickSite overwrites the 
graphic properties in all items (within the selected scope) with the current 
settings in the box. Therefore, be careful to select the scope you want so 
that you don’t inadvertently erase existing settings in the selected page or 
menu section.

To apply your changes
1. Double-click on any page in the Project View to display the Page 

Designer window.

The Page Designer box opens.

2. Click the Graphics Properties button.

The Graphics Properties box opens.

3. Select ONE of the following options.

Apply To Page

Applies any selection made in the Graphics Properties box to the 
selected page.

Apply To Menu Section

Applies any selection made in the Graphics Properties box to all pages 
within the current menu section.

Apply To Site

Applies any selection made in the Graphics Properties box to every 
page in the current file.

4. Click Save to save your changes and return to the Page Designer.

5. Click Save to save your changes in the Page Designer.
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Viewing the selected graphic
You can view a GIF file that you have selected in the Graphics Properties 
box.

Note This feature requires that you have a GIF viewer selected in the GIF 
Viewer Path/Executable field on the Preferences box. For more 
information, see Setting QuickSite preferences on page 3-13.

To view a graphic:
1. Double-click on any page in the Project View to display the Page 

Designer window.

The Page Designer box opens.

2. Click the Graphics Properties button.

The Graphics Properties box opens.

3. Click View. 

QuickSite launches your GIF viewer and displays the graphic in a 
window.

4. When you have finished viewing the graphic, click the Close box in 
the upper left corner to close the window.

Inserting an image component from the Project 
View

An alternative way to add a static or clickable graphic image to any page 
type (home, menu, text, form, or paragraph component) is to insert an 
image component from the Project View, then link it to the page.

You can also create a clickable GIF or ImageMap and add it as an image 
component.
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Adding a static graphic as an image component
You can add a static graphic, such as a GIF from the QuickSite library, or a 
custom graphic you created.

Note After you insert an image component through the Project View, you must 
link the component to the page or QuickSite will not know to include the 
graphic on the page. For more on linking, see Linking an image component 
to a page on page 9-8.

To add a static graphic
1. From the Project View, click the page under which you want to insert 

an image component.

2. In the Insert menu, choose Image Component.

QuickSite adds an untitled image component to the Project View 
under the page you selected.

3. Double-click the image component.

The Image Component Designer opens.

4. In the Image Description, type a name for the image component. This 
name identifies the image component in the Project View, but it is not 
displayed on the Web page.
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5. Click the “...” button (next to GIF File) to select a *.gif, *.jpg, or 
*.png file.

The Select Image File box appears.

6. In the Select Image File box, find the *.gif, *.jpg, or *.png file and 
click Open.

The filename appears in the GIF File window in the Image 
Component Designer.

7. In Web Page Status, scroll and click to select the page status. Default is 
Active.

8. Click Save to save the image component.

The image component appears in the Project View under the page 
where you inserted it.

9. Link the inserted image component to a page (see below).

Linking an image component to a page
As mentioned previously, when you insert an image component through 
the Project View, you must link it to the page where you want it to be 
displayed.

Tip You can link the graphic to more than one page. Just repeat the following 
process for each page. If the graphic changes, you must add it to your 
project again. QuickSite updates it on all pages to which it is linked. You 
can also change the file that the image component refers to by editing the 
images component’s image file path.

To link an image component
1. In the Project View, double-click the page where you want to link the 

graphic. The Page Designer opens.

2. In the Page Designer’s Optional Text window, click to mark the 
position where you want the image to appear.

3. In the Page Designer, click the Library and Project Links tool .
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4. Click Project Links and double-click the listed image component 
name for the graphic.

QuickSite inserts the image component in the text entry area of the 
Page Designer as ^image component name^. The ^  ̂symbols indicate 
the image component is included in the page and will be displayed.

5. Click Save.

QuickSite returns you to the Project View. When you build and test 
the Web site, the graphic appears on the page where you inserted it.

Creating a clickable graphic
You can add a hot spot to a static graphic to make it a clickable graphic. 
Clicking on the hot spot causes a jump to another page in your project or 
to another Web site.

To create a clickable graphic
1. Follow steps 1-11 of To add a static graphic on page 9-7.

2. In the URL or ImageMap window, type the *.htm file name for the 
page in your project where you want the user to jump to, such as 
mysite.htm to create a jump to the home page with that file name.

Or type the full URL (Uniform Resource Locator), an http address at 
another Web site such as http://www.mywebsite.com, to create a hot 
spot in another Web site to that address on the selected graphic.

3. Click Save.

4. Link the image to a page. See To link an image component on page 9-8.
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Turning off the QuickSite logo and navigation 
buttons

You can control preset, automatic graphic features that come with 
QuickSite.

If you are a registered user of DeltaPoint QuickSite, you can turn off the 
DeltaPoint QuickSite logo, . 

You can also turn off QuickSite-provided navigation buttons, such as:

To turn off the QuickSite logo
1. From the Project menu, choose Build Web Site.

The Web Construction Options box opens.

Note If you are not registered with QuickSite, the Include 
QuickSite Logo option is selected but grayed out. To register, 
contact DeltaPoint Sales at any of the numbers listed in How 
to Contact DeltaPoint in the Introduction.

2. Click to deselect (uncheck) the Include QuickSite logo checkbox, if it 
is checked.

 

Click to select or
deselect
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3. Click Build/Test to build and test the Web site.

The QuickSite logo does not appear on the Web pages.

To turn off navigation buttons
1. From the Project menu, choose Build Web Site.

2. Deselect (uncheck) the Include navigation buttons checkbox.

3. Click Build/Test to build and test the Web site.

The navigation buttons do not appear on the Web pages.
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10
Designing Tables 

With QuickSite, you can easily design and add table components to your 
Web pages. Tables are an important addition to any Web site. They 
organize otherwise unmanageable data into an easy-to-read structure that 
gives impact to your presentation. 

This chapter explains how to build customized tables using the Table 
Designer.

Building a table 
You can use the Table Designer to build a table component for the home 
page or any menu or text page. But first you need to insert a table 
component. Then you can define the table properties and fill in the table 
contents.

To insert a table 
1. In the Project View, click the page where you want to insert a table.

2. From the Insert menu, choose Table Component.

3. QuickSite inserts an Untitled Table Component under the selected 
page.

4. Double-click the Untitled Table Component.

The Table Designer opens. 
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5. Type a name for the table component. This name appears on the Web 
page.

6. In Table Status, scroll and click another page status as needed.

7. Enter data in the table as needed. For more information, see To fill in 
the table on page 10-3.

The table grid looks like a spreadsheet with rows and columns. The 
intersection of a row and column is a cell. You use the scroll bars and 
arrow keys to move to different rows and columns in the table grid.

To place text in a cell, click in the cell and enter your text. Then press 
Return to move the cursor to the next cell in the selected row. For each 
cell, repeat typing and entering until you finish all 7 columns. 
Numeric values and dollars are right justified automatically.

QuickSite generates the table only if it contains data. It generates rows 
and columns containing data ONLY. If a row or column is empty, 
QuickSite ignores it when building the HTML file.

Tip You can drag the column lines to change the column size. Just 
position the cursor on a column line at the top of the table, 
then hold down the mouse button while you move the mouse 
left or right.
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8. Optionally select any of these options:

Include In Page Contents List

Creates a hyperlink to the table component on the page that has the 
table. This feature is good for long pages that require extensive 
scrolling. A hyperlink allows users to access the table immediately

Display as New Table

Adds a New! icon, , next to the table and the table hyperlink on 
the Web page.

Display as Hot Table

Select to add a Hot! icon, , next to the table and the table 
hyperlink on the Web page.

Table Border

Displays a border around the table on the Web page.

9. Click Save.

QuickSite saves the properties you specified and closes the Table 
Component Page Properties box.

To fill in the table 
1. In the Table Designer, click in a cell.

The cell along with is associated row is highlighted.

2. Type text in the cell. 

3. Press Return or Tab to move to the next cell in the currently selected 
row.

You can also press Shift-Tab to move to the previous cell in the 
currently selected row.

4. Click in a cell in a different row to edit another row in the table. 

5. In the Table Designer, repeat steps 1-4 to enter text in the remaining 
table cells.
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Some things you should know...

QuickSite will generate the table only if it contains data in at least 
one cell.

If a row or column is empty, QuickSite ignores it when building 
the HTML file for the table. 

Numeric values and dollars are right-justified in the Web site 
display.

You do not have to delete extra rows and columns. QuickSite 
automatically adjusts the number of rows and columns at build 
time.

6. Click Save.

QuickSite lists the table component by its table name in the Project 
View. If you selected New! or Hot!, the Project View also lists the 
icons.

7. When you build and test the Web site, the table appears on the page. 

The sample below shows a table with various features added. 

 

Show title in page
contents list
Display as

New! Table

Alignment: Center

Gold star from
library

Border
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11
Linking to Files and URLs 

 

QuickSite makes it easy for you to

• Add hyperlinks on menu pages to downloadable resource files. 

• Create URL (Uniform Resource Locator) hyperlinks to other Web 
sites so that Web users can jump to those pages.

• Create links to external HTML files that have been created using 
HTML editing tools other than QuickSite.

This chapter explains how to design components that perform these tasks.

Linking to a file
You can use the File Link Designer to create a link to a file that your Web 
users can download to their computers. This allows you to create “mini” 
ftp sites on your Web page.

If you added file link components when you created your project with the 
New Project Wizard (see 

 

Selecting the Web site structure on page 3-6), and 
you want to use one of those components to add file links, skip steps 1-2.

To link to a file
1. In the Project View, click the menu page where you want to create the 

file link.

2. From the Insert menu, choose File Link.

QuickSite inserts a file link component, named File Item, below the 
selected page.

3. Double-click the file link component.
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The File Link Designer opens.

4. Click File to find and select the file name. Or type the full file path 
(drive:folder:filename) in File Name.

5. In Title, change the title for the descriptive title to something more 
meaningful if you want. The descriptive title is a hyperlink that 
appears on the Web page, as shown on page 11-3. When the user 
clicks the hyperlink, a description of the file appears.

6. In Description, type text you want displayed when the user clicks the 
descriptive title hyperlink (step 5). In this area you can specify the file 
size, in parentheses, so that users can estimate how long it will take to 
download.

7. In Status, scroll and click another status (Suspended, Hidden, etc.) as 
needed. 

8. Select Display As New Topic and/or Display As Hot Topic to display 
the New! and/or Hot! icons.
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9. Click Save.

10.When you build and test your Web site (Chapter 13, Building, Testing, 
and Publishing a Web Site), the file link appears on the page where you 
inserted it. The description you added to Resource Description (in 
step 6) appears when the user clicks the descriptive title hyperlink, in 
this case 

 

Build It

 

, in the Description column. 

 

filename
hyperlink

descriptive
title hyperlink
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Linking to a URL 
You can create a URL (Uniform Resource Locator) link on your Web page 
to another Web site or to other Web pages. 

To link a URL component
If you added URL file components when you created your project (see 
Selecting the Web site structure in Chapter 3), and you want to use one of 
those components to add URL links, skip steps 1-3.

1. In the Project View, click the menu page where you want to create the 
URL link.

2. From the Insert menu, choose URL Link.

3. QuickSite inserts a URL link component, with default title URL 
Component, below the selected page.

4. Double-click the URL component.

The URL Link Designer opens.

5. In URL, type the URL address. For example, if you type http://
www.deltapoint.com/, you tell the Web browser to use the HTTP 
(HyperText Transport Protocol) service to transfer across the Internet 
to DeltaPoint’s home page on the World Wide Web. Type another 
prefix, such as file:// or ftp://, as appropriate.
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If you are not sure of the address, check with the owner of the Web 
site or your Internet Service Provider (ISP). For more information on 
URLs, see Appendix A, Resources for the WWW.

6. In the Description, type information about the link for your reference. 
This information does not appear in your Web page.

7. In Constant, optionally type a constant value to create a URL 
component by referencing it inside an HREF (Hypertext REFerence) 
tag. 

This is a somewhat advanced feature that requires knowledge of 
HTML code. For those interested, an HREF tag makes the link live, 
causing the browser to do something which is defined by the constant 
value you specify.

URL components can be used inside HREF tags to achieve a high 
level of customization. For instance, you may not want the clickable 
text hyperlink for the URL to be the same as the URL title you gave 
the component.

For example,

<A HREF = ^constant^ Click here!!</A>

creates a hyperlink to the URL on the Click here!! text.

8. In Comments, type additional information about the URL. QuickSite 
does not display these comments. They are for your own information.

9. In Web Page Status, change the status for the component as needed.

10.Optionally select Display As New Topic or Display as Hot Topic.
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11.Click Save.

When you build and test your project, the URL links appear on the 
menu page. QuickSite automatically inserts the URL link icon in 
front of each link.

 

New URL link

Empty URL links

Display as 
Hot! topic
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Linking to an external HTML file
You can use the HTML Link Designer to create a link to HTML files that 
are external to QuickSite and are created with third-party HTML text 
editing software, such as Adobe PageMill and Claris HomePage.

To create an external HTML file link
1. In the Project View, click the home or menu page where you want to 

create the file link.

2. From the Insert menu, choose External HTML Page.

QuickSite inserts an empty component, named External HTML Page, 
below the selected page.

3. Double-click the External HTML Page component.

The HTML Link Designer opens.

4. Click File to find and select the HTML file name. Or type the full 
path (drive:folder:filename) for the HTML file in File Name.

5. In Description (below File Name), type the name of the external 
HTML page hyperlink. 

6. In the big Description window, optionally type a description of the 
file for your own information only.

7. In Web Page Status, scroll and click to change the page status.
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8. Optionally select Display as New Topic and/or Display as Hot Topic 
to display the New! and/or Hot! icons.

9. Click Save.

When you build and test your Web site (Chapter 13, Building, Testing, 
and Publishing a Web Site), the file hyperlink appears on the page 
where you inserted it. And when a Web user clicks the file hyperlink, 
An Additional HTML Page to Read

 

 in the example below, the 
external HTML file page displays.

 

External HTML
page title link

Display as 
New! topic
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12
Creating and Using 
Libraries

This chapter explains how you can use libraries to store and retrieve 
project items you plan to reuse later for other Web site projects. It also 
explains how to 

• Open and use a library.

• Create a custom library.

• Open and use a custom library.

• Edit a library.

• Copy project items to a project.

About libraries
QuickSite comes with a library of reusable graphics, pages, forms, URL 
links, calendars, style sheets, and so on. For instance, the QuickSite library 
provides a Welcome banner and other eye-appealing graphics that you can 
add to your Web site to produce immediate, professional-looking effects.

Rather than try to create items from scratch, you can easily transfer items 
between the QuickSite library and your project with just a few mouse 
clicks.

You can also:

• Adapt the QuickSite library items to fit your particular needs,

• Add your own materials to the QuickSite library,

• Create one or more custom libraries of your own. 
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A custom library is especially useful if you are developing multiple Web 
sites (see Managing related sites on page 5-9) or have multiple authors 
collaborating on the same Web site. You can keep frequently-used items in 
a central library for all sites that you can easily update in just one library 
file. For instance, a large company with multiple Web sites might want to 
maintain a central library of corporate information, such as the logo 
graphic, address, and phone numbers, plus maintain separate libraries for 
each department.

If you have multiple libraries, you can store each one in a separate folder; 
for example, you might have a central library stored in the QuickSite 
application folder and individual libraries stored in separate project 
folders. 

Each library is stored just like any QuickSite project, in two data files with 
names ending in *.dbf and *.dbt. The Quick Site library files are named 
library.dbf and library.dbt. You can work with libraries just like you 
would any QuickSite project, except that you do not typically build a Web 
site from a library.

Opening and using the QuickSite library
You can open the QuickSite library and add selected library information 
from the library to your current Web site project. The QuickSite library 
files, library.dbf and library.dbt, are in the QuickSite startup folder 
(default Macintosh HD:DeltaPoint QuickSite™ ). 

QuickSite looks first in the current project folder to open the library files, 
library.dbf and library.dbt. If it cannot find library files in the project 
folder, it searches the QuickSite startup folder. 

To open and use the QuickSite library
You can open the QuickSite library from the Project View. 

1. From the Library menu, choose Open Library.

Once QuickSite finds the library.dbf and library.dbt files, 
QuickSite lists the library items, as in the example below.
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2. In the Project View, click the page in the Project View above where 
you want to add a library item.

3. In the library list box, scroll and double-click the library item you 
want to add.

QuickSite adds the selected library item, including all its properties, to 
its place in the Project View.

4. When done selecting library items, click the close box in the upper left 
corner of the library list box.

Creating a custom library
You can create a new library that you store and maintain apart from the 
QuickSite library.

To create a library
1. From the Library menu, choose New Library.

The Create a new library file box opens.
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2. Select the drive and folder where you want QuickSite to create the 
library, such a Macintosh HD:DeltaPoint QuickSite™:mylibs. Click 
New to create a new folder if needed.

3. In File name, type the library name, such as NewLibrary.dbf. 

4. Click Save.

The Create a new library file box closes and QuickSite asks you 
whether you want to use the New Project Wizard. 

5. Click Yes.

6. Use the New Project Wizard to define preferences and page style for 
the library as you would for a new project file. For more information, 
see Creating a new Web site project on page 3-1. 

When the New Project Wizard finishes, QuickSite automatically 
generates the basic library structure, using the settings and structure 
you selected, and displays the structure in the Project View. Behind-
the-scenes, QuickSite saves the library in the folder you selected. 

7. To build a custom library, add and save the library items as you would 
project items. For more information, see the preceding chapters in this 
guide.

QuickSite saves the library in *.dbf and *.dbt files by the name you 
gave them in step 3. 

8. From the File menu, choose Close Project.

You can open and use the library you created whenever you want (see 
below).

Opening and using a custom library
If your project needs an item that already exists in a library, you can easily 
open the library and copy it into the project, then modify it as needed.

Important!...You must rename your custom library files as library.dbf 
and library.dbt whenever you want to use them as a library. See 
directions below.
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To open and use a custom library
1. From the File menu, choose Exit to exit QuickSite.

2. In the Macintosh Desktop, copy the custom library files (such as 
lib1.dbf and lib1.dbt) from the folder where you created them 
(such as Macintosh HD:DeltaPoint QuickSite™:mylibs) to the 
project folder where you want to open the library (such as Macintosh 
HD:DeltaPoint QuickSite™:mysite).

3. In your project folder, rename the files as library.dbf and 
library.dbt.

Note Leave the original QuickSite library files, also named 
library.dbf and library.dbt, unchanged in the QuickSite 
startup folder (default Macintosh HD:DeltaPoint 
QuickSite™ ). 

4. From the Library menu of the Project View, click Open Library.

QuickSite lists the custom library items.

5. In the Project View, click the page in the Project above where you want 
to add a library item.

A library list box opens.

6. In the library list box, scroll and double-click the library item you 
want to use.

QuickSite adds the selected library item, including all its properties, to 
the place you selected in the Project View.

7. When done selecting library items, click the close box in the upper left 
corner of the library list box.
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Editing a library
You can update a library as you do any other QuickSite project, through 
the Project View.

Tip It is okay to add a few items to the original QuickSite library, if you want. 
However, as a safeguard, we recommend you do not delete items from the 
original QuickSite library. 

If you intend to make substantial additions and changes to the QuickSite 
library, we recommend you copy the QuickSite library to another library 
folder and maintain it under a different file name (see Opening and using a 
custom library on page 12-4). That way you always have your original 
QuickSite library intact in case you need to go back to it. 

Then, when you want to use the custom library, just rename the files to 
library.dbf and library.dbt and place them in your project folder. 
QuickSite will look there first for a library file.

If for some reason the original QuickSite library becomes damaged, you 
can always reinstall QuickSite to restore it. 

To edit library contents
1. From the Library menu, choose Edit Library.

The Select a Library box opens.

2. Select the library (*.dbf) you want to edit.

3. Click Open.

QuickSite displays the library items in the Project View.

4. Change the library items as you would project items, as described in 
Chapters 7 through 11.
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Copying project items to a library
If you create an item in a project that you think might be useful for other 
projects, you can easily add it to a shared library so that other projects can 
use it. 

Before you copy...
If you are copying to a custom library, be sure the library has been 
renamed to library.dbf and library.dbt and is in the current project 
folder. 

To copy an item from current project 
1. In the Project View, click the item you want to copy to the library.

2. From the Library menu, choose Copy to Library.

The list of library items opens. 

3. In the library list, double-click the library item below where you want 
to insert the project item.

QuickSite adds the selected project item to the library.

Tip To make items easy to find later, try to group items of the 
same type together in the library list. Make sure all library 
items have unique names.

4. When done, click the close box in the upper left corner of the library 
list box.



End of Chapter
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13
Building, Testing, and 
Publishing a Web Site

This chapter describes the final steps of Web site creation — how to build, 
test, and publish your Web site project on the World Wide Web.

Building and testing a Web site
You can build and test the current project you are working on while in the 
Project View. You can build without testing or you can build and test at 
the same time.

When you build a Web site, QuickSite takes all the information in the 
project file (such as links, text, and graphics) and creates an entire Web 
site, complete with all the necessary HTML files. When you test the 
project, you preview the entire Web site locally on your Web browser. The 
local version of the test Web site looks just like it will on the World Wide 
Web.

Note You should always test your Web site after you have made changes to a 
project and before you publish it. If you have links to graphic and other 
files that are stored on a shared network drive, make sure you have access 
to that drive before starting to build and test your site.
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Selecting page features
You can select which text and graphic features to include or not include in 
your Web pages when you build the site.

To select page features
1. From the Project menu, choose Build Web Site, or click the Build 

Web Site tool, .

The Web Site Construction Options box opens. 

2. Under Include Automatic Table of Contents Link, select or deselect 
any or all of these options:

On The Home Page 

If selected, puts a Table of Contents navigation link on the home page. 
The link may be in the form of a navigation button and/or a text 
hyperlink, depending on the page features you select (see Page 
Features in step 3 below).

On All Menu Pages

If selected, puts Table of Contents links on all menu pages.

On All Text Pages

If selected, puts Table of Contents links on all text pages.
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3. Under Page Features, select or deselect any or all of these options:

Include Web author On Each Page

If selected, includes the Web author’s name on all Web pages. You can 
specify the Web author via Preferences in the Edit menu (see Setting/
resetting preferences on page 5-5).

Include Copyright On Each Page

If selected, includes the copyright, such as Copyright ©1996 by My 
Company, Inc. - ALL RIGHTS RESERVED, on all Web pages. You can 
specify the copyright via Preferences in the Edit menu (see Setting/
resetting preferences on page 5-5).

Include QuickSite Logo

If selected, includes the QuickSite logo button, , on all Web 
pages. 

Note To exclude the QuickSite button (by deselecting), you must 
be a registered QuickSite user. For more information, see 
Registering QuickSite on page 1-7.

Include Navigation Buttons

If selected, includes clickable buttons, such as:

,

as navigation links on all Web pages.

4. Under Build Options, select or deselect any or all of these options:

Display This Dialog Next Time

If selected, opens the Web Site Construction Options box each time 
you click Build Web Site in the Project menu.

If deselected, automatically builds and tests your Web site the next 
time without opening the Web Site Construction Options box (if you 
use the  tool). If you change your mind, you can always access the 
Web Construction Options box by clicking Build Web Site in the 
Project menu.

5. Click Build to build the site without testing it or Build/Test to build 
and test the site.
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QuickSite builds the Web site using the options you selected, 
assembling any defined links and creating all HTML files in the 
project folder. It stores the HMTL and associated graphics (as well as 
all supporting files such as ImageMaps and other resources you have 
shared in the project folder) in a publish folder in your project folder.

For example, if your project is named mysite, QuickSite would store 
the files in the Macintosh HD:DeltaPoint QuickSite™ :mysite 
:publish folder. All links are automatically maintained so that all 
graphics, hyperlinks, and other components remain intact.

If you selected Build/Test, QuickSite next launches your Web browser, 
such as Netscape Navigator, to test the site. The home page for your 
site automatically appears on the screen.

If you selected Build, you can test the site later (see Testing a Web site 
on page 13-5).

Viewing QuickSite/Web browser side-by-side
To view both the QuickSite Project View and browser windows side-by-
side. Resize the application windows to that you can see both 
simultaneously.

Note When both windows are open, each time you make a change in the Project 
View, the browser stops refreshing its screen as different pages are clicked. 
To make the browser refresh again, you must build or build and test the 
project.

Building and testing a single Web page
You can build and test a single Web page, with subordinate components 
and links, to quickly see the effects of your changes. You can build a single 
Web page at any time, but you can test a single Web page only after you 
have built and tested the entire Web site.

To build and test the current page
1. In the Project View, click the page you want to build. Click only a 

page (home, menu, text, and form), not a component or link.
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2. From the Project menu, choose Build Web Page, or click the Build 
Web Page tool, .

QuickSite automatically generates the HTML file for the page and its 
components/links.

3. To test the page, the browser must already be open, which means that 
you must build and test the Web site before you can test a current 
page.

Testing a Web site
After you have built your Web site or page, you can use your Web browser 
to view its appearance and test its operation. Web browsers allow you to 
locally test HTML documents without being currently connected to the 
Internet and running up connect time charges. See your browser 
documentation for more information.

Before you test...
Be sure to specify the Web Browser Path/Executable preference setting (see 
Setting/resetting preferences on page 5-5). 

To test a Web site
1. From the File menu, choose Open Project and select the Web site you 

want to test, if it is not already open.

2. From the Project menu, choose Test Web Site, or click the Test Web 
Site tool, .

QuickSite automatically loads your Web browser and displays the 
home page of the currently selected Web site.

Note In your Web browser, you might need to refresh or reload the 
current page, usually by clicking a Reload button, to ensure 
you are browsing the latest saved version of the site.

3. Browse the Web site, inspecting its appearance, testing links, checking 
graphics, and so on.

When done, hide or close the browser and go back to the Project 
View.
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4. Edit your Web site and rebuild and retest as needed.

Publishing on the World Wide Web
After you build and test your Web site locally and are satisfied with its 
appearance and operation, you are ready to publish it on the World Wide 
Web.

Before you publish...
Be sure to specify your publishing preferences — your user ID and 
password, port number, FTP server address, and FTP target folder. This 
information is obtained from your ISP or network administrator. For 
details on these settings, see Setting/resetting preferences on page 5-5.

Establish a connection with the Internet. Consult your Internet Service 
Provider (ISP) or network administrator to learn how to initiate your 
connection.You will be assigned an :http// address and physical space on 
the World Wide Web where you can publish a Web site.

To publish a Web site
When you are ready to publish your Web site, you must transfer all the 
necessary files to your Web server. QuickSite greatly simplifies this process. 
It takes just a few steps to get the job done, as described below.

1. Connect to your Web server according to the instructions provided by 
your ISP or network administrator.

2. From the Project menu, choose Publish, or click the Publish tool, .

The Web Site Construction Options box opens.

3. Set options as desired. For more information, see Building and testing 
a Web site on page 13-1.

4. Click Build.

QuickSite generates your Web site and stores all items used by your 
site in a publish folder in your project folder as when you build a site.
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5. QuickSite automatically logs onto your server and uploads your entire 
Web site to the FTP target folder you specified in Publishing 
Preferences (see Setting/resetting preferences on page 5-5).

The Publish message box opens. 

Tip If you encounter problems with publishing automatically, 
you may need to publish manually. To do this, you need to 
copy the contents of the publish folder for your project to 
the FTP target location on the Web server. Follow the 
instructions from your ISP or network administrator for 
manually transmitting and posting to your Web site.

6. Test your published Web site.

On your local drive

Using your browser, open the home page of the version stored in the 
publish folder. Inspect its appearance, test all links, check all graphics, 
and so on.

Doing this locally first reduces connect time charges and ensures that 
you have everything the way you want it before publishing on the 
Internet.

On the Internet

Using your browser, connect to your Web site via its http:// address 
and inspect its appearance, test all links, check all graphics, and so on.

Tip Test the site with other popular browsers to determine if any 
browser-specific problems arise.

End of Chapter
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A
Resources for the WWW

Appendix A briefly describes some on-line and printed resources to further 
help you understand and develop professional-looking web sites.

On the Web

Topic URL

DeltaPoint http://www.deltapoint.com

DeltaPoint QuickSite http://www.deltapoint.com/quicksite

NetScape Navigator ftp://ftp.netscape/com/netscape

Microsoft Internet Explorer http://www.microsoft.com/ie/ie.htm

HTML Resources http://www.ncsa.uiuc.edu/SDG/
Software/
Mosaic/Docs/Web-index.html

http://www.w3.org

General Information http://www.yahoo.com
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Publications
The number of books and magazines about the World Wide Web has 
exploded in recent years, and new ones are coming out every day! Some 
bookstores and libraries even have separate sections for books on the 
Internet and the World Wide Web. While it is impossible to put together a 
comprehensive list of publications, a few helpful ones include:

• Tim Evans, 10 Minute Guide to HTML. Indianapolis, Indiana: Que 
Corporation, 1995.

• William Horton, Lee Taylor, Arthur Ignacio, and Nancy L. Hoft, The 
Web Page Design Cookbook. New York: John Wiley & Sons, 1996.

• Taylor, Dave, Creating Cool Web Pages with HTML, Foster City, 
California: IDG Books, 1995.
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B
Glossary

active
Status setting. Specifies that the page, component, or link is generated in 
an HTML format, is INCLUDED when the project is built and, in the 
case of text, form, and menu pages, is automatically referenced by menu 
pages.

author
The name of the person primarily responsible for creating or maintaining 
a web site.

background
The backdrop on which you lay the components of your web site - text, 
graphics, and other information.

Backgrounds are commonly lighter gray in color, but you can use a wide 
variety of colors and textures.

body
The central portion of a web page containing the main body of 
information. Appears between the page header and footer.

bookmark
Netscape Navigator allows you to create a list of your favorite places on the 
World Wide Web. Each entry in this list, called a bookmark, contains the 
URL of a web page.
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In Netscape Navigator, to add an entry, you simply view the web page, 
then from the Bookmarks menu, choose Add Bookmark or press z-D. 
NetScape Navigator adds the URL to the bookmark.htm file in your 
NetScape folder.

You can then import this bookmark file in QuickSite and automatically 
generate link components to all the entries in the bookmark file.

browser
Software used to navigate the World Wide Web and view HTML 
documents.

bullet
A shape used to identify a list of parallel items.

Bullets can be circles, squares, diamonds, or other shapes.

In QuickSite, you can choose the graphic file associated with the bullet 
character. You can also have different graphics for bullets on different 
pages.

caret notation
References an item or template in the current project or a library. This 
feature allows you to use the power of HTML without needing to learn 
HTML coding. Also, because these references are not hard-coded items, 
you can change the referenced item in one location, then rebuild the page 
or site to have the changes reflected automatically.

Use caret notation by clicking the Links and Templates button in the 
designer dialogs and choosing Project Links or Library Links from the 
popup menu. This lets you insert graphics and other items (such as tables, 
forms, text pages, and more) into your Web pages. 

The format of the caret notation is:

^ItemTitle^ 

where ItemTitle is the text in the Title field of the selected component, 
enclosed in the caret character. For example, when referring to an image 
component named Company Background, the caret notation would be
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^Company Background^

The next time you build the page or project, QuickSite looks through all 
pages for caret references first, makes substitutes for links, images, and 
other components, then generates the reference in the HTML file using 
the correct HTML tags.

clickable GIF
A GIF file with a hyperlink.

component
A unit of information that can be linked to a text page.

copyright
Text that identifies the copyright holder of the material published in a web 
site. An example of copyright text is:

 Copyright 1996 by DeltaPoint, Inc. All rights reserved.

Just as if you published a book, you should include a copyright notice on 
your web site to legally protect your intellectual property. 

external HTML link
A logical link to an external HTML file.

Used for identifying HTML text that you want to include in your web 
site.

file link
A logical link to an external file. Used for posting files to be downloaded 
from your web site.

Consists of a file name and a description. The description should indicate 
the file size, in parentheses, so that users can estimate the time it might 
take to download the file. 

You can include any kind of file, including programs, spreadsheets, 
databases, documents, text, graphics, sound, and video.

Linked to menu pages ONLY.
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footer
The bottom portion of a web page, below the body.

The footer typically contains navigational buttons and supplemental 
information, such as the date the page was last updated and saved, the 
copyright notice, and so on.

footer line
A horizontal line that separates the footer and the body on a web page.

In QuickSite, you can choose the graphic file associated with the footer 
line. You can also have different graphics for footer lines on different 
pages.

form page
In a web site, a type of page that contains data entry fields laid out like a 
form.

Users can fill in the form and submit it to an e-mail address. 

FTP (file transfer protocol)
An Internet protocol for posting and downloading files across the network.

GIF (Graphics Interchange Format)
Popular file format for graphic images on the World Wide Web. GIF 
images are compressed and contain color palettes of 256 or fewer colors. 
They are often “interlaced” so that browsers can download them in 
sections.

GIF viewer
A software product that displays GIF files.

graphical browser
A browser that displays both text and graphics in an HTML document. 
See also browser.

header
The top portion of a web page, above the body.
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The header typically contains identifying information such as the page 
title, as well as other possible elements, such as graphics.

header line
A horizontal line that separates the header and the body of a web page.

In QuickSite, you can choose the graphic file associated with the header 
line. You can also have different graphics for header lines on different 
pages.

hidden
Status setting. Specifies that the page, component, or link is generated into 
an HTML format but NOT included when the project is built. As a 
result, no hyperlinks to this page are included in the web site.

Use this status setting when creating private pages. For example, a hidden 
page might be an internal company phone list.

Similarly, use this status for a page that you reference from a custom 
embedded link or from another web site.

Does NOT apply to file download links, URL links, paragraph 
components, or table components.

home page
In a web site, the first document displayed on a web site.

In a hierarchy of HTML documents, the home page is the top-most page.

hotspot
A portion of a graphics file that is a hyperlink to somewhere else. 

When a web site user clicks a hotspot on an ImageMap, for example, their 
browser takes them to the defined target location, such as another site, 
another page within the current site, or a component within the current 
page.

HTML (hypertext markup language)
Set of codes used to design, lay out, format, and program documents that 
appear on the World Wide Web.
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HTML is an evolving coding standard. 

QuickSite generates HTML automatically, but you can also author your 
own HTML in QuickSite Designers.

HTML editor
A software program used to modify HTML files, including design, layout, 
and formatting.

QuickSite provides a text editor that you can use to embed HTML codes 
directly into text.

In addition, you can use any of many popular third party products to 
create and edit HTML files. Some common WYSIWYG HTML editors 
include:

• Microsoft Word with the Internet Assistant

• Adobe PageMill

• Claris HomePage

HTML file 
A text file containing embedded HTML codes.

HTML files end with *.htm or *.html extensions.

In a QuickSite project, the home page has the same filename as the 
project. For example, the home page of a project called MYSITE would 
have the filename mysite.htm.

The names of all other files in a QuickSite project begin with the first two 
letters of the project name, then have a 5-digit number that QuickSite 
generates based on the order and layout of the web site. For example, a 
menu page in the MYSITE project might be named my01000.htm.

HTTP (HyperText Transport Protocol)
Communications standard used to connect to the World Wide Web.
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hyperlink
A link that, when clicked, takes the user to another location, such as 
another page or a paragraph component within a page.

Hyperlinks can be represented with text or graphics.

HyperSite
QuickSite technology that enables you, with a few mouse clicks, to build, 
test, and publish your web site.

Using HyperSite technology, QuickSite can automatically log into your 
web server, as long as you are connected to the Internet, and install all the 
files you need to run a professional-looking web site professionally.

image component
A reference to a graphic file and the properties associated with it, including 
HTTP commands and ImageMaps. 

Use the Links and Templates button in a QuickSite Designer to add 
images to the body of your web pages.

ImageMap
An image that contains one or more hot links. User can jump to different 
locations depending on where they click on the graphic.

An ImageMap consists of a GIF file and a separate .MAP file that contains 
the hot spot coordinates and associated target hyperlinks in the GIF file. 
To use ImageMaps, these files must be used in conjunction. MAP files are 
created by editing the GIF file using MapEdit, MapThis, or other third 
party program.

Note To use ImageMaps, you should be an advanced user with knowledge of 
web servers and CGI. You cannot test ImageMaps locally - only when you 
are connected via the Internet to your web site on your web server.

in construction
Status setting. Specifies that the page, component, or link is generated to 
an HTML file and is INCLUDED when the project is built, but that the 
In Construction icon appears next to it in hypertext links.
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Use this status to indicate that a page that is currently under construction, 
like a draft that is not yet ready for final publication.

Internet
World-wide network of computers that can talk with each other using a 
group of communications standards, including HTTP.

ISP (Internet service provider)
A company that provides access to the Internet for a fee.

item
One of the following parts of a QuickSite project.

home page
The top-level page in your Web site to which all other pages and 
components are linked.

JPG (JPEG image)
A popular compressed image format often used to display images and 
photographs on the World Wide Web. JPEG images use lossy 
compression. That is, in order to achieve smaller image sizes, some image 
information is lost, resulting in somewhat poorer quality compared to the 
original image.

library
A collection of shared pages, components, and links stored in a QuickSite 
project file named library.dbf.

You can have multiple libraries. QuickSite comes with a default library, 
stored in the QuickSite application folder, that contains boilerplate web 
pages and images. You can add to this library and you can create your own 
libraries and store them in separate folders, such as web site project folders. 
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link
Text or graphics used to jump to other items in a web site.

QuickSite supports the following types of links:

• file links

• HTML links

• URL links

QuickSite also lets you create special links to items in your projects and 
libraries in order to insert references to graphics, text pages, forms, tables, 
paragraphs, and more.

load time
Time it takes the browser software to load and display an HTML 
document.

master home page
The home page for a web site with multiple subordinate sites.

For example, a company web site might have one corporate web site with 
its home page. Individual departments might have subordinate web sites 
with their own project home pages as well. Project home pages in the 
department web sites would be linked to the master home page of the 
corporate site.

In a hierarchy of web sites, the master home page is the top-most page.

menu page
In a web site, a page that contains a list of hyperlinked choices to other 
pages.

menu section
A menu page and all its subordinate components.

Mosaic
Popular graphical web browser.
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navigation buttons
Hyperlinks used to navigate within the web site to places such as the home 
page, table of contents, and other common destinations.

Navigational buttons can be: 

• text buttons

• graphical buttons

In QuickSite, you can choose either style simply by choosing Include 
Navigational Buttons on the Web Site Construction Options dialog box. 

Netscape Navigator
Popular graphical web browser.

page
QuickSite supports the following types of pages:

• home page

• text page

• menu page

• form page

page contents list
A table of contents for a text page.

paragraph component
A unit of text that, when the web site is built, is assembled into a text page. 

A text page can contain one or more paragraph components. A text page 
can also provide a page table of contents containing hypertext links to each 
paragraph.

Linked to text pages ONLY. Paragraph components can be mixed in with 
table components under the same text page.
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project
All the items needed for QuickSite to build a complete web site, including 
pages, components, links, text, and graphics. QuickSite stores and 
maintains all this web site information in a project file database. The 
project file is like the genetic DNA for your web site.

project file
A database file that contains all the components of a project. QuickSite 
uses this database file to manage all the pages in your web site and to 
generate all the HTML code.

Each QuickSite project has two files, with .DBF and .DBT extensions. 
These files are stored in the project folder.

For example, a project named MYSITE consists of two files, mysite.dbf 
and mysite.dbt, which reside in the mysite folder, such as Macintosh 
HD:DeltaPoint QuickSite™:mysite.

project home page
The home page for the current project.

In a hierarchy of web sites, with one master site and multiple subordinate, 
satellite sites, the project home page is the home page of a satellite site. 

For example, a company web site might have one corporate web site with 
its master home page. Individual departments might have subordinate, 
satellite web sites with their own project home pages as well. Project home 
pages are usually linked to the master home page of the master site.

protocol
A communications standard that defines the language of a conversation 
between a user and an Internet resource. Common Internet protocols and 
access methods include: 

http:// hypertext transport protocol

file:// local disk drive

ftp:// file transport protocol

gopher:// gopher

mailto: electronic mail
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publish
To copy or upload an HTML document, or a set of documents, and 
supporting files to a web server.

QuickSite automates this process by logging onto your server and 
uploading your entire web site and its supporting files.

status
Current status of an item. One of the following settings:

• active

• in construction

• hidden

• suspended

suspended
Status setting. Specifies that the page, component, or link is NOT 
generated to an HTML page and is NOT included when the project is 
built. As a result, no physical links to this page are included in the web site.

Rather than deleting an item, use this status setting to retain the item in 
the project. Suspending items keeps items used in earlier builds, thereby 
ensuring an audit trail and version control for your web site.

table component
An item that contains information in a tabular format.

A table contains a grid of rows and columns, column titles, and a table 
title.

A text page can contain one or more table components. A text page can 
also provide a page table of contents containing hypertext links to each 
table.

Linked to text pages ONLY. Table components can be mixed in with 
paragraph components under the same text page.
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table of contents
A list of the contents of a web site or a text page, with links to each entry 
in the list:

• In a web site, the table of contents links to each page in the site.

• In a text page, the table of contents, also called the page contents list, 
links to any paragraph components or table components it contains.

tag
Set of codes used in an HTML document to format text, define links, 
specify graphics, and so on.

template
An existing item that you can copy into a project for editing.

Instead of starting from scratch, use templates whenever possible to get a 
head start on designing an item.

text page
In a web site, a type of page that can contain text, paragraph components, 
image components, and table components.

title
Tag that identifies the title of an HTML document.

URL (Uniform Resource Locator)
Naming method used to identify files on the Internet. Includes the server 
type, host name of the computer on which the file is stored, and the file 
path.

URL link
A logical link to another page, usually a home page on another site, using 
its URL.

When QuickSite builds a URL link, it creates a text hyperlink that, when 
clicked by a web site user, jumps to the associated page.

Linked to menu pages ONLY.
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Web page
An HTML document published on the world wide web.

Web server
A computer that contains one or more web sites and provides HTML 
documents for viewing.

Web site
A collection of HTML documents stored on a web server.

World Wide Web
An Internet service that lets you view multimedia text, graphics, sound, 
and video. You can read hypertext (HTML) documents stored on a Web 
server by connecting to it via the Hypertext Transport Protocol (HTTP).
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graphics 7-8
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Locking text format 7-8
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showing only 4-13
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Menu pages 7-7
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